summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikuro Kagamine2018-01-23 22:47:02 +1000
committerMikuro Kagamine2018-01-23 22:47:02 +1000
commit49bf3f80e1d62101995a65c13ab7f3fd12feee56 (patch)
treec95b2b5e0f2f39509b89d6344171c7dfe5c0faec
downloadaur-49bf3f80e1d62101995a65c13ab7f3fd12feee56.tar.gz
Initial package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f092b5c88dfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = squashfs-tools-git
+ pkgdesc = Tools for squashfs, a highly compressed read-only filesystem for Linux.
+ pkgver = 1806.fb33dfc
+ pkgrel = 1
+ url = https://github.com/plougher/squashfs-tools
+ arch = x86_64
+ license = GPL2
+ depends = zlib
+ depends = lzo
+ depends = xz
+ depends = lz4
+ depends = zstd
+ provides = squashfs-tools
+ conflicts = squashfs-tools
+ source = squashfs-tools::git+https://github.com/plougher/squashfs-tools.git
+ md5sums = SKIP
+
+pkgname = squashfs-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5534ab3560b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Mikuro Kagamine <mikurok@forgecrushing.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Original TU: Jeff Mickey <j@codemac.net>
+# Contributor: ciccio.a
+
+pkgname=squashfs-tools-git
+_pkgbasename=squashfs-tools
+pkgver=1806.fb33dfc
+pkgrel=1
+pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
+url="https://github.com/plougher/squashfs-tools"
+license=("GPL2")
+arch=('x86_64')
+depends=('zlib' 'lzo' 'xz' 'lz4' 'zstd')
+conflicts=('squashfs-tools')
+provides=('squashfs-tools')
+source=("squashfs-tools::git+https://github.com/plougher/squashfs-tools.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgbasename}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
+ CFLAGS="$CFLAGS -O2" make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 ZSTD_SUPPORT=1
+}
+
+package() {
+ cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
+ install -Dm755 mksquashfs "$pkgdir"/usr/bin/mksquashfs
+ install -m755 unsquashfs "$pkgdir"/usr/bin/unsquashfs
+}