summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2015-06-25 00:05:02 +0200
committerzoe2015-06-25 00:05:02 +0200
commit446f95110b52ad175e83481e48feb67ea15834c7 (patch)
treefd685b9bf6bece5e47311453aa18488dbf920c68
downloadaur-446f95110b52ad175e83481e48feb67ea15834c7.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e058ddb9fe0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = squeak-image
+ pkgdesc = Image file for squeak VM
+ pkgver = 4.6
+ pkgrel = 3
+ url = http://www.squeak.org
+ arch = any
+ license = custom:MIT
+ license = custom:XEROX
+ license = APACHE
+ depends = squeak-vm
+ source = http://ftp.squeak.org/current_development/Squeak4.6-14191.zip
+ md5sums = 67074af2126af4b54b9edbf74250cc12
+
+pkgname = squeak-image
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff195be65401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+## Contributor: Markus Maiwald <mail@maiwald.tk>
+## Maintainer: zoe <chp321@gmail.com>
+
+pkgname=squeak-image
+pkgver=4.6
+bid=14191
+pkgrel=3
+arch=('any')
+pkgdesc="Image file for squeak VM"
+url="http://www.squeak.org"
+license=('custom:MIT' 'custom:XEROX' 'APACHE')
+depends=('squeak-vm')
+source=(http://ftp.squeak.org/current_development/Squeak$pkgver-$bid.zip)
+md5sums=('67074af2126af4b54b9edbf74250cc12')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/squeak
+
+ install -m644 Squeak$pkgver-$bid.image $pkgdir/usr/lib/squeak/Squeak$pkgver-$bid.image
+ install -m644 Squeak$pkgver-$bid.changes $pkgdir/usr/lib/squeak/Squeak$pkgver-$bid.changes
+
+ ln -s Squeak$pkgver-$bid.image $pkgdir/usr/lib/squeak/squeak.image
+ ln -s Squeak$pkgver-$bid.changes $pkgdir/usr/lib/squeak/squeak.changes
+} \ No newline at end of file