summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiras Zaidan2015-06-10 00:25:09 +0200
committerFiras Zaidan2015-06-10 00:25:09 +0200
commit5a2c91a1da20c3380d4f81e9c6b9975ca5fd7113 (patch)
treefa79dea2b7b7324e3662eec91b1f5a5c3f95803f
downloadaur-5a2c91a1da20c3380d4f81e9c6b9975ca5fd7113.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6d56f9f8d4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = squeak-sources-41
+ pkgdesc = Source code file required by Squeak to view function names, source code, etc. within the VM.
+ pkgver = 41
+ pkgrel = 1
+ url = http://www.squeak.org
+ arch = any
+ license = Apache
+ depends = squeak-vm
+ source = http://ftp.squeak.org/sources_files/SqueakV41.sources.gz
+ sha512sums = f2ec7320ddb73b2da8d8bbde190f44d502aec6b26f9a219960118d23410a3ee0f8dd708d65e36098b48ee56a58f41a270ed5ebaafe688b896b719d61e1161b24
+
+pkgname = squeak-sources-41
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5fc744dd2d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: fqqbar
+# Contributor: Matthew Longley <randomticktock@gmail.com>
+
+pkgname='squeak-sources-41'
+pkgver='41'
+pkgrel='1'
+pkgdesc='Source code file required by Squeak to view function names, source code, etc. within the VM.'
+arch=('any')
+url='http://www.squeak.org'
+license=('Apache')
+depends=('squeak-vm')
+source=("http://ftp.squeak.org/sources_files/SqueakV$pkgver.sources.gz")
+sha512sums=('f2ec7320ddb73b2da8d8bbde190f44d502aec6b26f9a219960118d23410a3ee0f8dd708d65e36098b48ee56a58f41a270ed5ebaafe688b896b719d61e1161b24')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/squeak"
+ install -m644 "$srcdir/SqueakV$pkgver.sources" "$pkgdir/usr/lib/squeak/SqueakV$pkgver.sources"
+}