summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Dzieciolowski2018-06-24 00:41:42 +0200
committerPawel Dzieciolowski2018-06-24 00:41:42 +0200
commit01a0cb820b0af3a5e62497ac35277fa75ee4a8e4 (patch)
treed8b723d8d502a469b60abac81842bb8dbff4b2af
downloadaur-01a0cb820b0af3a5e62497ac35277fa75ee4a8e4.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5a6211527ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = squeue
+ pkgdesc = Simple queue implementation based on Screen command
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/dzieciolowski/squeue
+ arch = any
+ license = MIT
+ depends = screen
+ depends = coreutils
+ depends = bash
+ source = v1.0.0.zip::https://github.com/dzieciolowski/squeue/archive/v1.0.0.zip
+ sha256sums = a7371389ec5790b8bd7f0279fe325efc02c00b2a04cb8f96778ef87df8275902
+
+pkgname = squeue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86b4efee19a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Pawel Dzieciolowski <dzieciolowski dot pawel at gmail dot com>
+
+pkgname=squeue
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Simple queue implementation based on Screen command'
+arch=('any')
+url='https://github.com/dzieciolowski/squeue'
+license=('MIT')
+depends=('screen' 'coreutils' 'bash')
+source=("v${pkgver}.zip::https://github.com/dzieciolowski/${pkgname}/archive/v${pkgver}.zip")
+sha256sums=('a7371389ec5790b8bd7f0279fe325efc02c00b2a04cb8f96778ef87df8275902')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm 755 squeue "${pkgdir}/usr/bin/squeue"
+}