summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbar0metr2018-08-16 11:14:31 +0500
committerbar0metr2018-08-16 11:14:31 +0500
commit5517e656f264151e975b841be03e37b85db2f956 (patch)
tree415cfefd1675660155d4c806d97e609cf8cc4d2c
parent83d8c5ac99730fc1751d53300d7f2b8bd5f7ab3b (diff)
downloadaur-5517e656f264151e975b841be03e37b85db2f956.tar.gz
Add libtcmalloc and compiler flags...
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1b6009ec77b..4e1f47acafb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,7 @@ pkgbase = squid4
depends = nettle
depends = gnutls
depends = libnsl
+ depends = gperftools
conflicts = squid
conflicts = squid4
conflicts = squid5
diff --git a/PKGBUILD b/PKGBUILD
index 83f1f05fcd57..7bcf3b5e5864 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgrel=4
pkgdesc='Full-featured Web proxy cache server with the support SSL, eCAP, iCAP-client. Include patches for normal work with cache, long url`s and CDN.'
arch=('x86_64')
url='http://www.squid-cache.org'
-depends=('openssl' 'libecap' 'pam' 'perl' 'libltdl' 'libcap' 'nettle' 'gnutls' 'libnsl')
+depends=('openssl' 'libecap' 'pam' 'perl' 'libltdl' 'libcap' 'nettle' 'gnutls' 'libnsl' 'gperftools')
makedepends=('krb5')
conflicts=('squid' 'squid4' 'squid5')
license=('GPL')
@@ -90,7 +90,12 @@ build() {
--disable-arch-native \
--disable-strict-error-checking \
--enable-wccpv2 \
- --enable-ssl-crtd
+ --enable-ssl-crtd \
+ --with-build-environment=POSIX_V6_LP64_OFF64 \
+ 'CFLAGS=-g -O2 -fPIE -fstack-protector-strong -DNDEBUG -Wformat -Werror=format-security -Wall -ltcmalloc_minimal' \
+ 'LDFLAGS=-fPIE -pie -Wl,-z,relro -Wl,-z,now' \
+ 'CPPFLAGS=-D_FORTIFY_SOURCE=2' \
+ 'CXXFLAGS=-g -O2 -fPIE -fstack-protector-strong -DNDEBUG -Wformat -Werror=format-security -ltcmalloc_minimal'
make -j$(nproc)
}