summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbar0metr2018-08-16 11:31:40 +0500
committerbar0metr2018-08-16 11:31:40 +0500
commitcfb7e96270eae8901b6d394a4e081aeb87438ca2 (patch)
treebd67992c2722d9b04e924bff5126229848bdeb21
parent5517e656f264151e975b841be03e37b85db2f956 (diff)
downloadaur-cfb7e96270eae8901b6d394a4e081aeb87438ca2.tar.gz
Correct configure options
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e1f47acafb6..34b8a07499c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = squid4
makedepends = krb5
depends = openssl
depends = libecap
+ depends = libnetfilter_conntrack
depends = pam
depends = perl
depends = libltdl
diff --git a/PKGBUILD b/PKGBUILD
index 7bcf3b5e5864..d4333c1cda6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgrel=4
pkgdesc='Full-featured Web proxy cache server with the support SSL, eCAP, iCAP-client. Include patches for normal work with cache, long url`s and CDN.'
arch=('x86_64')
url='http://www.squid-cache.org'
-depends=('openssl' 'libecap' 'pam' 'perl' 'libltdl' 'libcap' 'nettle' 'gnutls' 'libnsl' 'gperftools')
+depends=('openssl' 'libecap' 'libnetfilter_conntrack' 'pam' 'perl' 'libltdl' 'libcap' 'nettle' 'gnutls' 'libnsl' 'gperftools')
makedepends=('krb5')
conflicts=('squid' 'squid4' 'squid5')
license=('GPL')
@@ -62,15 +62,19 @@ build() {
--enable-icap-client \
--enable-auth \
--enable-auth-basic \
- --enable-auth-ntlm \
- --enable-auth-digest \
+ --disable-auth-ntlm \
+ --disable-auth-digest \
--enable-auth-negotiate \
--enable-removal-policies="lru,heap" \
- --enable-storeio="aufs,ufs,diskd,rock" \
+ --enable-storeio="ufs,aufs,diskd,rock" \
--enable-delay-pools \
--enable-arp-acl \
+ --enable-zph-qos \
+ --with-netfilter-conntrack \
--with-openssl=/usr/include/openssl \
--enable-snmp \
+ --enable-xmalloc-statistics \
+ --enable-inline \
--enable-linux-netfilter \
--enable-ident-lookups \
--enable-useragent-log \
@@ -90,6 +94,7 @@ build() {
--disable-arch-native \
--disable-strict-error-checking \
--enable-wccpv2 \
+ --disable-wccp \
--enable-ssl-crtd \
--with-build-environment=POSIX_V6_LP64_OFF64 \
'CFLAGS=-g -O2 -fPIE -fstack-protector-strong -DNDEBUG -Wformat -Werror=format-security -Wall -ltcmalloc_minimal' \