summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2017-06-20 12:50:53 +0530
committerAmish2017-06-20 12:50:53 +0530
commit029956711b480cc19e42746d100558fb3eb1e9c6 (patch)
tree56f2fe8da6033fa985f4fc0eb186f945d614c5ef
downloadaur-029956711b480cc19e42746d100558fb3eb1e9c6.tar.gz
Initial version 6.6
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD56
-rw-r--r--squidanalyzer.cron2
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..310642c09ab1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Jun 20 07:20:00 UTC 2017
+pkgbase = squidanalyzer
+ pkgdesc = Squid proxy native log analyser and reports generator
+ pkgver = 6.6
+ pkgrel = 1
+ url = http://squidanalyzer.darold.net/
+ arch = any
+ license = GPL
+ depends = cron
+ depends = perl
+ options = !emptydirs
+ options = purge
+ backup = etc/squidanalyzer/excluded
+ backup = etc/squidanalyzer/included
+ backup = etc/squidanalyzer/network-aliases
+ backup = etc/squidanalyzer/squidanalyzer.conf
+ backup = etc/squidanalyzer/user-aliases
+ source = http://downloads.sourceforge.net/project/squid-report/squid-report/6.6/squidanalyzer-6.6.tar.gz
+ source = squidanalyzer.cron
+ md5sums = d70f5c747d0666a92410fdca734c494b
+ md5sums = e8c2657f7a2eb544d6c246f5eca02e8b
+
+pkgname = squidanalyzer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ef397e92678
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*-any.pkg.tar.xz
+squidanalyzer-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e428604cea36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Amish <contact at via dot aur>
+
+pkgname='squidanalyzer'
+pkgver='6.6'
+pkgrel='1'
+pkgdesc="Squid proxy native log analyser and reports generator"
+arch=('any')
+url='http://squidanalyzer.darold.net/'
+license=('GPL')
+options=('!emptydirs' 'purge')
+depends=('cron' 'perl')
+source=("http://downloads.sourceforge.net/project/squid-report/squid-report/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.cron"
+ )
+md5sums=('d70f5c747d0666a92410fdca734c494b'
+ 'e8c2657f7a2eb544d6c246f5eca02e8b')
+backup=(
+ 'etc/squidanalyzer/excluded'
+ 'etc/squidanalyzer/included'
+ 'etc/squidanalyzer/network-aliases'
+ 'etc/squidanalyzer/squidanalyzer.conf'
+ 'etc/squidanalyzer/user-aliases'
+ )
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor \
+ QUIET=1 \
+ LOGFILE=/var/log/squid/access.log \
+ BINDIR=/usr/bin \
+ CONFDIR=/etc/${pkgname} \
+ HTMLDIR=/srv/http/${pkgname} \
+ BASEURL=/${pkgname} \
+ MANDIR=/usr/share/man/man3 \
+ DOCDIR=/usr/share/doc/${pkgname} \
+ DESTDIR="$pkgdir"
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ install -dm755 "${pkgdir}"/etc/cron.daily
+ install -Dm700 ../${pkgname}.cron "${pkgdir}"/etc/cron.daily/${pkgname}
+}
diff --git a/squidanalyzer.cron b/squidanalyzer.cron
new file mode 100644
index 000000000000..ae86dc25d9f1
--- /dev/null
+++ b/squidanalyzer.cron
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/squid-analyzer > /dev/null 2>&1