summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-30 18:58:21 +0100
committerJaroslav Lichtblau2014-11-30 18:58:21 +0100
commit69f629a702603cbeb5ef6fb090a1ffe52af04e3f (patch)
tree0f94aecc0e3a0ee6a11da3a28996803f36a80340
parent9e2c3f6614491c7e1b73334b3059fc939a33af76 (diff)
downloadaur-69f629a702603cbeb5ef6fb090a1ffe52af04e3f.tar.gz
squirrel-3.0.6-1
-rw-r--r--.SRCINFO11
-rwxr-xr-xPKGBUILD69
-rw-r--r--patch-0.2.diff11
3 files changed, 40 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7ca80ad5fc7..7258f1a5f6b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = squirrel
- pkgdesc = A light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games.
- pkgver = 3.0.4
+ pkgdesc = A light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games
+ pkgver = 3.0.6
pkgrel = 1
url = http://www.squirrel-lang.org/
arch = i686
arch = x86_64
license = MIT
- options = strip
- source = http://squirrel.googlecode.com/files/squirrel_3_0_4_stable.tar.gz
- source = patch-0.2.diff
- md5sums = e75feaed79c203d027708e2067ca1dcc
- md5sums = af31d80d92f6f30eae4871f389c95a15
+ source = http://sourceforge.net/projects/squirrel/files/squirrel3/squirrel%203.0.6%20stable/squirrel_3_0_6_stable.tar.gz
+ md5sums = a873eaf63a8d40af696eb055fa184d76
pkgname = squirrel
diff --git a/PKGBUILD b/PKGBUILD
index b1787ea1313b..f170d84764b3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,59 @@
-# Maintainer: Ilgrim <ilgrim at gmail dot com>
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Ilgrim <ilgrim at gmail dot com>
pkgname=squirrel
-pkgver=3.0.4
+pkgver=3.0.6
pkgrel=1
-pkgdesc="A light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games."
+pkgdesc="A light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games"
arch=('i686' 'x86_64')
url="http://www.squirrel-lang.org/"
-source=("http://squirrel.googlecode.com/files/${pkgname}_3_0_4_stable.tar.gz"
- "patch-0.2.diff")
-md5sums=('e75feaed79c203d027708e2067ca1dcc'
- 'af31d80d92f6f30eae4871f389c95a15')
license=('MIT')
-options=('strip')
+source=(http://sourceforge.net/projects/squirrel/files/squirrel3/squirrel%203.0.6%20stable/${pkgname}_3_0_6_stable.tar.gz)
+md5sums=('a873eaf63a8d40af696eb055fa184d76')
+
build() {
- # Patching source of libsquirrel Makefile. Added -fPIC param to make command.
- patch -Np1 < patch-0.2.diff
- cd ${srcdir}/SQUIRREL3
- # If $arch is x86_64, compile for 64bits. Else do it for 32.
+ cd "${srcdir}"/SQUIRREL3
+# If $arch is x86_64, compile for 64bits. Else do it for 32.
if [ $CARCH=='x86_64' ]; then
- make sq64
+ make sq64
else
- make sq32
+ make sq32
fi
}
package() {
- # Install squirrel Interpreter.
- install -Dm755 ${srcdir}/SQUIRREL3/bin/sq ${pkgdir}/usr/bin/squirrel
- # Install Includes and various headers.
- for _file in $(ls ${srcdir}/SQUIRREL3/include)
+ cd "${srcdir}"/SQUIRREL3
+
+# Install squirrel Interpreter
+ install -Dm755 bin/sq "${pkgdir}"/usr/bin/$pkgname
+
+# Install Includes and various headers
+ for _file in $(ls "${srcdir}"/SQUIRREL3/include)
do
- install -Dm755 ${srcdir}/SQUIRREL3/include/$_file ${pkgdir}/usr/include/$_file
+ install -Dm644 include/$_file "${pkgdir}"/usr/include/$_file
done
- # Install all static libraries & others.
- for _file in $(ls ${srcdir}/SQUIRREL3/lib)
+# Install all static libraries & others
+ for _file in $(ls "${srcdir}"/SQUIRREL3/lib)
do
- install -Dm755 ${srcdir}/SQUIRREL3/lib/$_file ${pkgdir}/usr/lib/$_file
+ install -Dm644 lib/$_file "${pkgdir}"/usr/lib/$_file
done
- # Install docs & examples.
- for _file in $(ls ${srcdir}/SQUIRREL3/doc)
+
+# Install docs & examples.
+ for _file in $(ls "${srcdir}"/SQUIRREL3/doc)
do
- install -Dm755 ${srcdir}/SQUIRREL3/doc/$_file ${pkgdir}/usr/share/$pkgname/doc/$_file
+ install -Dm644 doc/$_file "${pkgdir}"/usr/share/$pkgname/doc/$_file
done
- for _file in $(ls ${srcdir}/SQUIRREL3/samples)
+ for _file in $(ls "${srcdir}"/SQUIRREL3/samples)
do
- install -Dm755 ${srcdir}/SQUIRREL3/samples/$_file ${pkgdir}/usr/share/$pkgname/samples/$_file
+ install -Dm644 samples/$_file "${pkgdir}"/usr/share/$pkgname/samples/$_file
done
- # Install Other docs.
- install -Dm755 ${srcdir}/SQUIRREL3/HISTORY ${pkgdir}/usr/share/$pkgname/HISTORY
- install -Dm755 ${srcdir}/SQUIRREL3/README ${pkgdir}/usr/share/$pkgname/README
- for _file in $(ls ${srcdir}/SQUIRREL3/etc)
+
+# Install Other docs
+ install -Dm644 COPYRIGHT "${pkgdir}"/usr/share/licenses/$pkgname/COPYRIGHT
+ install -Dm644 HISTORY "${pkgdir}"/usr/share/$pkgname/HISTORY
+ install -Dm644 README "${pkgdir}"/usr/share/$pkgname/README
+ for _file in $(ls "${srcdir}"/SQUIRREL3/etc)
do
- install -Dm755 ${srcdir}/SQUIRREL3/etc/$_file ${pkgdir}/usr/share/$pkgname/embebing/$_file
- done
+ install -Dm644 etc/$_file "${pkgdir}"/usr/share/$pkgname/embebing/$_file
+ done
}
diff --git a/patch-0.2.diff b/patch-0.2.diff
deleted file mode 100644
index 840675e65ef4..000000000000
--- a/patch-0.2.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/SQUIRREL3/squirrel/Makefile.orig 2012-04-28 17:53:44.692923733 +0200
-+++ src/SQUIRREL3/squirrel/Makefile 2012-04-28 17:54:52.326256786 +0200
-@@ -3,7 +3,7 @@
-
- OUT= $(SQUIRREL)/lib/libsquirrel.a
- INCZ= -I$(SQUIRREL)/include -I. -Iinclude
--DEFS=
-+DEFS= -fpermissive -fPIC
- LIB=
-
- OBJS= \