summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rosenstrauch2015-07-21 23:05:47 -0400
committerDavid Rosenstrauch2015-07-21 23:05:47 -0400
commitf6eaef586f841ec184cd81f0d253a8587a2357b1 (patch)
tree0205083d62677e8d8d6bf9be45fdde21de04f735
downloadaur-f6eaef586f841ec184cd81f0d253a8587a2357b1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
-rw-r--r--squirrelmail.install17
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e13cc1668cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = squirrelmail
+ pkgdesc = Webmail for Nuts!
+ pkgver = 1.4.22
+ pkgrel = 1
+ url = http://www.squirrelmail.org
+ install = squirrelmail.install
+ arch = any
+ license = GPL
+ depends = php
+ depends = perl
+ depends = imap-server
+ backup = srv/http/squirrelmail/.htaccess
+ backup = srv/http/squirrelmail/config/config.php
+ source = http://downloads.sourceforge.net/sourceforge/squirrelmail/squirrelmail-webmail-1.4.22.tar.bz2
+ source = http://downloads.sourceforge.net/sourceforge/squirrelmail/squirrelmail-webmail-1.4.22.tar.bz2.sig
+ md5sums = 494016b82762e57dca009fd9cc77ac2e
+ md5sums = eddabb7071e008c41308d957ff8c3e32
+
+pkgname = squirrelmail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5de5bffe96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 140402 2011-10-12 20:25:08Z eric $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Manolis Tzanidakis <manolis@archlinux.org>
+
+pkgname=squirrelmail
+pkgver=1.4.22
+pkgrel=1
+pkgdesc="Webmail for Nuts!"
+arch=('any')
+license=('GPL')
+url="http://www.squirrelmail.org"
+depends=('php' 'perl' 'imap-server')
+backup=(srv/http/squirrelmail/.htaccess srv/http/squirrelmail/config/config.php)
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-webmail-$pkgver.tar.bz2{,.sig})
+md5sums=('494016b82762e57dca009fd9cc77ac2e'
+ 'eddabb7071e008c41308d957ff8c3e32')
+
+package() {
+ # install
+ mkdir -p "$pkgdir"/srv/http/squirrelmail
+ cd "$pkgdir"/srv/http/squirrelmail
+ cp -a "$srcdir"/squirrelmail-webmail-$pkgver/* .
+
+ # remove CVS dirs
+ find "$pkgdir" -type d -name CVS -exec rm -rf {} \;
+
+ # customize config (data and attachments in /var/lib/squirrelmail)
+ cd config
+ cp -p config_default.php config.php
+ sed -i 's|^$attachment_dir = $data_dir;|$attachment_dir = "/var/lib/squirrelmail/attachments";|' config.php
+ sed -i 's|^$data_dir = "/var/local/squirrelmail/data";|$data_dir = "/var/lib/squirrelmail/data";|' config.php
+
+ # create data and attachments directories, set ownership/permissions
+ # ideally we would set attachments differently to root:-1 with 0730, but
+ # I don't know how to get chgrp to take "-1" properly; perhaps someday
+ # I'll figure out how to make this work
+ mkdir -p "$pkgdir"/var/lib/squirrelmail/{data,attachments}
+ chown -R http:http "$pkgdir"/var/lib/squirrelmail/data
+
+ chown -R http:http "$pkgdir"/var/lib/squirrelmail/attachments
+
+ chmod 0700 "$pkgdir"/var/lib/squirrelmail/data
+ chmod 0300 "$pkgdir"/var/lib/squirrelmail/attachments
+
+ # restrict access to squirrelmail by default
+ echo "deny from all" >"$pkgdir"/srv/http/squirrelmail/.htaccess
+}
+
+# vim: ts=2 sw=2 et ft=sh
diff --git a/squirrelmail.install b/squirrelmail.install
new file mode 100644
index 000000000000..565cc68cf1ca
--- /dev/null
+++ b/squirrelmail.install
@@ -0,0 +1,17 @@
+post_install() {
+ /bin/cat <<THEEND
+
+NOTE
+----
+To configure squirrelmail :
+$ cd /srv/http/squirrelmail/config
+$ perl conf.pl
+
+Make sure to check the documentation on its webpage for more details,
+especially about securing your setup. The default attachments dir
+has been placed in /var/lib/squirrelmail/attachments.
+
+Also make sure your php module is loaded in your Apache config.
+
+THEEND
+}