summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2018-03-04 12:45:40 -0500
committerGötz Christ2018-03-04 12:46:17 -0500
commit39749783685d06c277050763f18a1b22bc636edb (patch)
tree7ad64ab660edee0639afd4324e4fbe67c13831e6
parent8413999ce47ae463940d7c033dfeebcf31c82b56 (diff)
downloadaur-39749783685d06c277050763f18a1b22bc636edb.tar.gz
Fix FTBFS
And use spaces instead of tabs in the PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8fe6b3b7715..f7fba6d4bbb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = squishyball
- pkgdesc = Perform sample comparison testing on the command line
- pkgver = 19599
+ pkgdesc = Perform ABX audio sample comparison testing on the command line
+ pkgver = 19643
pkgrel = 1
url = https://svn.xiph.org/trunk/squishyball/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d1da2ce274d7..f5fa4b5d9f64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Gaetan Bisson <bisson@archlinux.org
+# Maintainer: goetzc
+# Contributor: Gaetan Bisson <bisson@archlinux.org
pkgname=squishyball
-pkgver=19599
+pkgver=19643
pkgrel=1
-pkgdesc='Perform sample comparison testing on the command line'
+pkgdesc='Perform ABX audio sample comparison testing on the command line'
url='https://svn.xiph.org/trunk/squishyball/'
arch=('i686' 'x86_64')
license=('GPL2')
@@ -12,19 +13,25 @@ depends=('opusfile' 'ncurses' 'libvorbis' 'flac' 'libao')
source=("svn+https://svn.xiph.org/trunk/squishyball/")
sha1sums=('SKIP')
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ # Fix compile, from Debian bug tracker #860334
+ sed -i '/#define _FILE_OFFSET_BITS/a#define NCURSES_INTERNALS' mincurses.c
+}
+
pkgver() {
- cd "${srcdir}/${pkgname}"
- svn info | awk '/Revision/{print $2}'
+ cd "${srcdir}/${pkgname}"
+ svn info | awk '/Revision/{print $2}'
}
build() {
- cd "${srcdir}/${pkgname}"
- sed 's:@MANDIR@:/usr/share/man:' -i Makefile.am
- ./autogen.sh --prefix='/usr'
- make
+ cd "${srcdir}/${pkgname}"
+ sed -i 's:@MANDIR@:/usr/share/man:' Makefile.am
+ ./autogen.sh --prefix='/usr'
+ make
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
}