summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-11-06 12:43:33 -1000
committerGaetan Bisson2015-11-06 12:43:33 -1000
commit88c050c1fd65a99245269c841b6679a147bf9914 (patch)
treef57114bfc2ace7e00eb44e2c36c911fd73281a1b
downloadaur-88c050c1fd65a99245269c841b6679a147bf9914.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f86d2d47a0c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = squishyball-svn
+ pkgdesc = Perform sample comparison testing on the command line
+ pkgver = 20140210.19518
+ pkgrel = 1
+ url = https://svn.xiph.org/trunk/squishyball/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ depends = opusfile
+ depends = ncurses
+ depends = libvorbis
+ depends = flac
+ depends = libao
+ provides = squishyball
+ conflicts = squishyball
+ source = svn+https://svn.xiph.org/trunk/squishyball/
+ sha1sums = SKIP
+
+pkgname = squishyball-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2034cedcbd8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org
+
+pkgname=squishyball-svn
+_pkgname=squishyball
+pkgver=20140210.19518
+pkgrel=1
+pkgdesc='Perform sample comparison testing on the command line'
+url='https://svn.xiph.org/trunk/squishyball/'
+arch=('i686' 'x86_64')
+license=('GPL2')
+makedepends=('subversion')
+depends=('opusfile' 'ncurses' 'libvorbis' 'flac' 'libao')
+source=("svn+https://svn.xiph.org/trunk/squishyball/")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ sed 's:@MANDIR@:/usr/share/man:' -i Makefile.am
+ ./autogen.sh --prefix='/usr'
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}