summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorapolih2016-01-29 16:50:35 -0600
committerapolih2016-01-29 16:50:35 -0600
commit42fce0d305257071d3e49d540a80e90f8372e858 (patch)
treefeb493549f34279fb251279ded598ad3b3d3f5ef
downloadaur-42fce0d305257071d3e49d540a80e90f8372e858.tar.gz
initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..847de0b6a055
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 22:50:27 UTC 2016
+pkgbase = sra-tools
+ pkgdesc = The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives.
+ pkgver = 2.5.7
+ pkgrel = 1
+ url = http://www.ncbi.nlm.nih.gov/Traces/sra/
+ arch = x86_64
+ license = custom:PublicDomain
+ depends = libxml2
+ depends = file
+ depends = hdf5
+ depends = ngs
+ depends = ncbi-vdb
+ optdepends = fuse: mount remote genome reference files
+ provides = sra-tools
+ source = sra-tools-2.5.7.tar.gz::https://github.com/ncbi/sra-tools/archive/2.5.7.tar.gz
+ sha256sums = 854a23da7ca49026adf4ca7adee65e9387389d6a55568c403be87442cec32361
+
+pkgname = sra-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47e94bcebac3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is the PKGBUILD for sra-tools
+# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
+
+pkgname=sra-tools
+pkgver=2.5.7
+pkgrel=1
+pkgdesc="The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives."
+arch=('x86_64')
+url="http://www.ncbi.nlm.nih.gov/Traces/sra/"
+depends=('libxml2' 'file' 'hdf5' 'ngs' 'ncbi-vdb')
+optdepends=('fuse: mount remote genome reference files')
+provides=('sra-tools')
+license=('custom:PublicDomain')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ncbi/sra-tools/archive/$pkgver.tar.gz")
+sha256sums=('854a23da7ca49026adf4ca7adee65e9387389d6a55568c403be87442cec32361')
+
+prepare(){
+ cd $pkgname-$pkgver
+
+ # sra-tools tries to link to hdf5 as a static library but Arch provides this as
+ # a dynamic library https://bbs.archlinux.org/viewtopic.php?id=208018
+ sed -e 's/-shdf5/-lhdf5/' -i tools/pacbio-load/Makefile
+}
+
+build(){
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix="$pkgdir/usr/" --with-ngs-sdk-prefix=/usr --with-ncbi-vdb-sources="/usr/src/ncbi-vdb-2.5.7"
+ make
+}
+
+check(){
+ cd "${pkgname}-${pkgver}"
+ make -k test
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ make "ROOT=$pkgdir" install
+
+ # add the license
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}