summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2017-08-11 22:58:12 +0800
committerShengyu Zhang2017-08-11 22:58:12 +0800
commit000d6e0728d9d53e17bc86d8f557b2562ac71612 (patch)
tree34a723b4c71c6996ae0cd0b0854179e919c6dcc8
parent6a6b6cb8b89866a7ddb2c8c8c3711ecc8a0015af (diff)
downloadaur-000d6e0728d9d53e17bc86d8f557b2562ac71612.tar.gz
srain-dev: fix startup script and add dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea3683e9f801..a99cebba409c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jul 30 14:23:41 UTC 2017
+# Fri Aug 11 14:57:53 UTC 2017
pkgbase = srain-dev
pkgdesc = Modern, beautiful IRC client written in GTK+ 3, develop and debug version
- pkgver = 0.682.7e22a1e
+ pkgver = 0.713.2ddb6dc
pkgrel = 1
url = https://srain.im
arch = i686
@@ -20,6 +20,7 @@ pkgbase = srain-dev
depends = libnotify
depends = libconfig
depends = gdb
+ depends = libsoup
optdepends = glib-networking: TLS connection support
optdepends = python-sphinx: for generating documentation
optdepends = python-urllib3: avatar and pastebin support
diff --git a/PKGBUILD b/PKGBUILD
index 821bcf78a2ee..48945f3fdad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Shengyu Zhang <arch at srain.im>
pkgname=srain-dev
-pkgver=0.682.7e22a1e
+pkgver=0.713.2ddb6dc
pkgrel=1
pkgdesc="Modern, beautiful IRC client written in GTK+ 3, develop and debug version"
arch=('i686' 'x86_64')
license=('GPL')
url="https://srain.im"
makedepends=('git' 'make' 'gcc' 'pkg-config' 'gettext' 'imagemagick')
-depends=('gtk3' 'python' 'curl' 'libnotify' 'libconfig' 'gdb')
+depends=('gtk3' 'python' 'curl' 'libnotify' 'libconfig' 'gdb' 'libsoup')
optdepends=(
'glib-networking: TLS connection support'
'python-sphinx: for generating documentation'
@@ -44,8 +44,8 @@ package() {
mv ${pkgdir}${_prefix}/bin/srain{,-dev}
cat << EOF > ${pkgdir}${_prefix}/bin/srain
-!/bin/sh
-gdb ${_prefix}/bin/srain-dev -ex 'r' -ex 'bt' -ex 'q'
+#!/bin/sh
+gdb ${_prefix}/bin/srain-dev -ex "r \$@" -ex "bt" -ex "q"
EOF
chmod 755 ${pkgdir}${_prefix}/bin/srain