summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Fuentes2019-01-22 14:56:45 -0500
committerVictor Fuentes2019-01-22 14:56:45 -0500
commitfd62df85581f5fd98ba4375181cf52feab172440 (patch)
tree11d263baa8b717685352901b337bbc2370e9c889
parent3f33e21688e708c349e30f1dac4a5f1a7f23d2fe (diff)
downloadaur-fd62df85581f5fd98ba4375181cf52feab172440.tar.gz
Clear out CPPFLAGS
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dfe2e6c4f90..0715ab944f33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = srb2kart
pkgdesc = A kart racing mod based on the 3D Sonic the Hedgehog fangame Sonic Robo Blast 2, based on a modified version of Doom Legacy.
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://mb.srb2.org/showthread.php?t=43708
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7f8b7d1631d4..6ae64f5b7453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=srb2kart
pkgver=1.0.2
_dataver=1.0.2
_patchver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='A kart racing mod based on the 3D Sonic the Hedgehog fangame Sonic Robo Blast 2, based on a modified version of Doom Legacy.'
arch=('i686' 'x86_64')
license=('GPL')
@@ -36,7 +36,10 @@ prepare() {
build() {
cd Kart-Public/src
- # do not upx binary (optional: show warnings, be verbose)
+ # clear out CPPFLAGS ( -D_FORTIFY_SOURCE doesn't like kart )
+ CPPFLAGS=""
+
+ # do not use upx binary (optional: show warnings, be verbose)
CC="cc -m32" make LINUX=1 NOUPX=1 #WARNINGMODE=1 #ECHO=1
}