summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsecond20502021-08-28 23:15:41 +0200
committersecond20502021-08-28 23:15:41 +0200
commit3fc51ca1754c23dc63b6c61cee67d910a09f6f25 (patch)
tree49e956a63cf3b9ba5b52226828c6bffaefe5a6ac
downloadaur-3fc51ca1754c23dc63b6c61cee67d910a09f6f25.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD67
-rwxr-xr-xsrb2kart-moe-mansion-opengl.desktop9
-rwxr-xr-xsrb2kart-moe-mansion.desktop9
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3ee88fb782
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = srb2kart-moe-mansion-git
+ pkgdesc = A rolling release/nightly version of srb2kart 1.3 based on birdhouse with a couple other changes.
+ pkgver = r7357.a3939035
+ pkgrel = 1
+ url = https://mb.srb2.org/threads/srb2kart-1-3-moe-mansion.29473/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = mesa
+ makedepends = glu
+ makedepends = git
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = libpng
+ depends = libgme
+ depends = srb2kart-data>=1.3
+ conflicts = srb2kart-moe-mansion
+ options = !buildflags
+ source = git+https://gitlab.com/himie/kart-public.git
+ source = srb2kart-moe-mansion.desktop
+ source = srb2kart-moe-mansion-opengl.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ makedepends_i686 = nasm
+
+pkgname = srb2kart-moe-mansion-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884b5bdd5935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: second2050 <dilan.neusa+aur at gmail dot com
+# Contributor: steeltitanium <steeltitanium1 at gmail dot com>
+
+# Variables which can be customized at build time. Use env or export to set
+
+## Discord Rich Presence integration
+## Required for game invites.
+if [ -z ${_use_discordrpc+x} ]; then
+ _use_discordrpc=n
+fi
+
+# Don't compress with UPX, don't dump symbols to speed up compiling
+_buildflags="NOUPX=1 NOOBJDUMP=1 "
+
+pkgname=srb2kart-moe-mansion-git
+pkgver=r7357.a3939035
+_dataver=1.3
+pkgrel=1
+pkgdesc="A rolling release/nightly version of srb2kart 1.3 based on birdhouse with a couple other changes."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url='https://mb.srb2.org/threads/srb2kart-1-3-moe-mansion.29473/'
+depends=('sdl2' 'sdl2_mixer' 'libpng' 'libgme' "srb2kart-data>=$_dataver")
+makedepends=('mesa' 'glu' 'git')
+makedepends_i686=('nasm')
+conflicts=('srb2kart-moe-mansion')
+
+if [ "${_use_discordrpc}" = "y" ]; then
+ depends+=('discord-rpc-api')
+fi
+
+options=(!buildflags)
+source=("git+https://gitlab.com/himie/kart-public.git"
+ "srb2kart-moe-mansion.desktop"
+ "srb2kart-moe-mansion-opengl.desktop")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $srcdir/kart-public
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"/kart-public/src
+
+ [ "$CARCH" == "x86_64" ] && _buildflags+="LINUX64=1 " || _buildflags+="LINUX=1 "
+
+ if [ "${_use_discordrpc}" = "y" ]; then
+ _buildflags+="HAVE_DISCORDRPC=1"
+ fi
+
+ echo "Build options: $_buildflags"
+ make $_buildflags
+}
+
+package() {
+ [ "$CARCH" == "x86_64" ] && IS64BIT="64" || IS64BIT=""
+ install -Dm755 "$srcdir"/kart-public/bin/Linux$IS64BIT/Release/lsdl2srb2kart \
+ "$pkgdir"/usr/bin/srb2kart-moe-mansion
+
+ # icon + .desktop
+ install -Dm644 "$srcdir"/kart-public/src/sdl/SDL_icon.xpm "$pkgdir"/usr/share/pixmaps/srb2kart-moe-mansion.xpm
+ install -Dm644 srb2kart-moe-mansion.desktop "$pkgdir"/usr/share/applications/srb2kart-moe-mansion.desktop
+ install -m644 srb2kart-moe-mansion-opengl.desktop "$pkgdir"/usr/share/applications/
+}
diff --git a/srb2kart-moe-mansion-opengl.desktop b/srb2kart-moe-mansion-opengl.desktop
new file mode 100755
index 000000000000..041e56d6d6e8
--- /dev/null
+++ b/srb2kart-moe-mansion-opengl.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Sonic Robo Blast 2 Kart - Moe Mansion (OpenGL)
+Comment=Classic styled kart racer
+GenericName=A 3D open-source kart racing game
+Exec=srb2kart-moe-mansion -opengl
+Icon=srb2kart-moe-mansion
+Terminal=false
+Categories=Game;ArcadeGame
diff --git a/srb2kart-moe-mansion.desktop b/srb2kart-moe-mansion.desktop
new file mode 100755
index 000000000000..75e2d9b5f154
--- /dev/null
+++ b/srb2kart-moe-mansion.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Sonic Robo Blast 2 Kart - Moe Mansion
+Comment=Classic styled kart racer
+GenericName=A 3D open-source kart racing game
+Exec=srb2kart-moe-mansion
+Icon=srb2kart-moe-mansion
+Terminal=false
+Categories=Game;ArcadeGame