summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvicencb2015-06-28 18:23:22 +0100
committervicencb2015-06-28 18:23:22 +0100
commit0256cc2a8b862829ce80ebd0c3da0a5b5f237e0f (patch)
tree1b7ed3bd91903f6a97b78c8a5afe5e8be3b94434
downloadaur-0256cc2a8b862829ce80ebd0c3da0a5b5f237e0f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df599b42a801
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = srecord
+ pkgdesc = The SRecord package is a collection of powerful tools for manipulating EPROM load files.
+ pkgver = 1.64
+ pkgrel = 1
+ url = http://srecord.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = ghostscript
+ options = !makeflags
+ source = http://srecord.sourceforge.net/srecord-1.64.tar.gz
+ md5sums = 4de4a7497472d7972645c2af91313769
+
+pkgname = srecord
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1d56b1eb8cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=srecord
+pkgver=1.64
+pkgrel=1
+pkgdesc="The SRecord package is a collection of powerful tools for manipulating EPROM load files."
+arch=('i686' 'x86_64')
+license=('GPL')
+makedepends=('boost' 'ghostscript')
+url="http://srecord.sourceforge.net"
+source=("${url}/${pkgname}-${pkgver}.tar.gz")
+# broken makefile has race conditions, remove "-j"
+options=('!makeflags')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums=('4de4a7497472d7972645c2af91313769')