summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustanoobcoder2020-05-09 15:11:07 +0700
committerjustanoobcoder2020-05-09 15:11:07 +0700
commit0c77584f9b5786665931061bfa0db566a8d883b5 (patch)
treeb8cedd1a7689360467e50462471e61fe4e5699ef
downloadaur-0c77584f9b5786665931061bfa0db566a8d883b5.tar.gz
initial push
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cc1a7e85314
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = srfetch-git
+ pkgdesc = This is modified neofetch script only for me.
+ pkgver = 7.0.0.r1.b0bb11c
+ pkgrel = 1
+ url = https://github.com/justanoobcoder/srfetch.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = make
+ depends = bash
+ optdepends = catimg: Display Images
+ optdepends = chafa: Image to text support
+ optdepends = feh: Wallpaper Display
+ optdepends = imagemagick: Image cropping / Thumbnail creation / Take a screenshot
+ optdepends = jp2a: Display Images
+ optdepends = libcaca: Display Images
+ optdepends = nitrogen: Wallpaper Display
+ optdepends = pacman-contrib: Display package count
+ optdepends = w3m: Display Images
+ optdepends = xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
+ optdepends = xorg-xdpyinfo: Resolution detection (Single Monitor)
+ optdepends = xorg-xprop: Desktop Environment and Window Manager
+ optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
+ optdepends = xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
+ backup = etc/srfetch/config.conf
+ source = git+https://github.com/justanoobcoder/srfetch.git
+ md5sums = SKIP
+
+pkgname = srfetch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3ed8687748a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Syaoran Code <syaorancode@gmail.com>
+
+pkgname=srfetch-git
+_dir=srfetch
+pkgver=7.0.0.r1.b0bb11c
+pkgrel=1
+pkgdesc="This is modified neofetch script only for me."
+arch=(x86_64 i686)
+url="https://github.com/justanoobcoder/srfetch.git"
+license=('MIT')
+depends=(bash)
+makedepends=(make)
+backup=('etc/srfetch/config.conf')
+optdepends=(
+ 'catimg: Display Images'
+ 'chafa: Image to text support'
+ 'feh: Wallpaper Display'
+ 'imagemagick: Image cropping / Thumbnail creation / Take a screenshot'
+ 'jp2a: Display Images'
+ 'libcaca: Display Images'
+ 'nitrogen: Wallpaper Display'
+ 'pacman-contrib: Display package count'
+ 'w3m: Display Images'
+ 'xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
+ 'xorg-xdpyinfo: Resolution detection (Single Monitor)'
+ 'xorg-xprop: Desktop Environment and Window Manager'
+ 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
+ 'xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
+)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_dir}"
+ printf "%s.r%s.%s" "$(awk -F'=' '/^version=/ {print $2}' srfetch)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_dir}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}