summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2020-02-26 22:30:58 +0100
committerThorben Günther2020-02-26 22:30:58 +0100
commit51fe58566dd217d3bc466acc343c4f5c5e4c6306 (patch)
tree8d922c9eb6b0586378ca94980548a118390b44fb
parentebc5ae9021f3d41cca12bdeb4fac236a490e6bf6 (diff)
downloadaur-51fe58566dd217d3bc466acc343c4f5c5e4c6306.tar.gz
upgpkg: srhtctl 0.3.0-1
upstream release add completions for bash and zsh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97db4bc82fea..bb4b489cf86f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = srhtctl
pkgdesc = CLI for interacting with the sr.ht API
- pkgver = 0.2.0
+ pkgver = 0.3.0
pkgrel = 1
url = https://git.xenrox.net/~xenrox/srhtctl
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = srhtctl
makedepends = git
makedepends = go-pie
provides = srhtctl
- source = srhtctl-0.2.0.tar.gz::https://git.xenrox.net/~xenrox/srhtctl/archive/0.2.0.tar.gz
- sha256sums = cf50c4033ee16089a49c882b5c439136c8271ea84a577377ea76b43a4b291e49
+ source = srhtctl-0.3.0.tar.gz::https://git.xenrox.net/~xenrox/srhtctl/archive/0.3.0.tar.gz
+ sha256sums = d8efdc964e9d99ab4ecf086be30d00b5bc49ed74de5d2ec303e87086e16f17eb
pkgname = srhtctl
diff --git a/PKGBUILD b/PKGBUILD
index 4d1307e5f48d..b710bfdbce00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thorben Günther <echo YWRtaW5AeGVucm94Lm5ldAo= | base64 -d>
pkgname=srhtctl
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
pkgdesc='CLI for interacting with the sr.ht API'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
makedepends=('git' 'go-pie')
provides=('srhtctl')
source=("$pkgname-$pkgver.tar.gz::https://git.xenrox.net/~xenrox/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('cf50c4033ee16089a49c882b5c439136c8271ea84a577377ea76b43a4b291e49')
+sha256sums=('d8efdc964e9d99ab4ecf086be30d00b5bc49ed74de5d2ec303e87086e16f17eb')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -19,5 +19,9 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR=$pkgdir install
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ "$pkgdir/usr/bin/srhtctl" completionBASH | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/srhtctl"
+ "$pkgdir/usr/bin/srhtctl" completionZSH | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_srhtctl"
+ patch --forward --strip=1 --input="$srcdir/$pkgname-$pkgver/assets/srhtctl.patch" --directory="$pkgdir"
}