summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2020-06-09 13:55:02 +0200
committerThorben Günther2020-06-09 13:55:02 +0200
commit8b0fcefc2bf1df6abe821efed11f8255c237c21f (patch)
tree491eb0880f76687919446babadf5a97985f84ead
parentb7e295b06ae39a77e44fb8ce01465bbb70fb990e (diff)
downloadaur-8b0fcefc2bf1df6abe821efed11f8255c237c21f.tar.gz
upgpkg: srhtctl 0.4.0-3
New go package standard
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1e3b2e3ba23..49fbfc74384d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = srhtctl
pkgdesc = CLI for interacting with the sr.ht API
pkgver = 0.4.0
- pkgrel = 2
- url = https://git.xenrox.net/~xenrox/srhtctl
+ pkgrel = 3
+ url = https://hub.xenrox.net/~xenrox/srhtctl/
arch = x86_64
license = GPL3
makedepends = git
- makedepends = go-pie
- provides = srhtctl
+ makedepends = go
source = srhtctl-0.4.0.tar.gz::https://git.xenrox.net/~xenrox/srhtctl/archive/0.4.0.tar.gz
sha256sums = b513f29fad270445156fd034ffa3da8d2ccf9bfcee70dbb9c7c70cbe8e608657
diff --git a/PKGBUILD b/PKGBUILD
index d539644f72ad..0d186d10555e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
pkgname=srhtctl
pkgver=0.4.0
-pkgrel=2
+pkgrel=3
pkgdesc='CLI for interacting with the sr.ht API'
arch=('x86_64')
-url='https://git.xenrox.net/~xenrox/srhtctl'
+url='https://hub.xenrox.net/~xenrox/srhtctl/'
license=('GPL3')
-makedepends=('git' 'go-pie')
-provides=('srhtctl')
+makedepends=('git' 'go')
source=("$pkgname-$pkgver.tar.gz::https://git.xenrox.net/~xenrox/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('b513f29fad270445156fd034ffa3da8d2ccf9bfcee70dbb9c7c70cbe8e608657')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
make PREFIX=/usr
}