summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Ammann2015-12-21 21:52:37 +0100
committerMax Ammann2015-12-21 21:52:37 +0100
commit414bf92aa1ad267b88201b3e497bc76dfb7cc055 (patch)
treebd459df0e2ef05f08e92cc988ccb3b3f963b7a4d
downloadaur-414bf92aa1ad267b88201b3e497bc76dfb7cc055.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d79bf9932149
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 20:51:14 UTC 2015
+pkgbase = srmio
+ pkgdesc = library + command line tools to access a "Schoberer Rad Messtechnik" PowerControl V, VI and 7 + read/write their files
+ pkgver = 0.1.1~git1
+ pkgrel = 1
+ url = http://www.zuto.de/project/srmio/
+ arch = i686
+ arch = x86_64
+ license = custom: Rainer Clasen
+ makedepends = gcc
+ makedepends = make
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://www.zuto.de/project/files/srmio/srmio-0.1.1~git1.tar.gz
+ md5sums = badca33309f469930e13a7d40ea6eadf
+
+pkgname = srmio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec6741395cec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
+pkgname=srmio
+pkgver=0.1.1~git1
+pkgrel=1
+pkgdesc="library + command line tools to access a \"Schoberer Rad Messtechnik\" PowerControl V, VI and 7 + read/write their files"
+arch=('i686' 'x86_64')
+url="http://www.zuto.de/project/srmio/"
+license=('custom: Rainer Clasen')
+makedepends=('gcc' 'make')
+depends=()
+options=('!strip' '!buildflags' 'staticlibs')
+source=(http://www.zuto.de/project/files/srmio/srmio-0.1.1~git1.tar.gz)
+md5sums=(badca33309f469930e13a7d40ea6eadf)
+
+build() {
+ cd "${srcdir}/srmio-$pkgver/"
+ ./configure
+ make -j8
+}
+
+package() {
+ cd "${srcdir}/srmio-$pkgver/"
+ make DESTDIR="$pkgdir/" install
+}