summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Kromlinger2021-06-25 15:49:06 +0200
committerJustin Kromlinger2021-06-25 15:49:39 +0200
commitc76e23fd213c308aad302eb0ea2d6f8f0ba4c4b6 (patch)
tree31cb0deba7a65a01f91b96eda32c5be91616500a
parent81cac4debc86dfb46c2fee15798cf523a422b040 (diff)
downloadaur-c76e23fd213c308aad302eb0ea2d6f8f0ba4c4b6.tar.gz
Bump pkgver to 1.9.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e46c407e420..da1a5231aac9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by mksrcinfo v8
-# Fri Apr 30 17:03:13 UTC 2021
pkgbase = srs-state-threads
pkgdesc = Fork of state-threads, patched for SRS
- pkgver = 1.9.1
- pkgrel = 2
+ pkgver = 1.9.2
+ pkgrel = 1
url = https://github.com/ossrs/state-threads/
arch = x86_64
license = GPL2
license = MPL
makedepends = git
- source = git+https://github.com/ossrs/state-threads/#commit=29472f83ce03bd55770df929e5bd0af99c43988d
+ source = git+https://github.com/ossrs/state-threads/#commit=1d48ef5317f306adb232b440bab11327f9ae3883
sha256sums = SKIP
pkgname = srs-state-threads
-
diff --git a/PKGBUILD b/PKGBUILD
index ae4f78c5571e..4fdd83e4e2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: heinrich5991 <heinrich5991@gmail.com>
+# Maintainer: Justin Kromlinger <hashworks@archlinux.org>
+# Contributor: heinrich5991 <heinrich5991@gmail.com>
pkgname=srs-state-threads
-pkgver=1.9.1
-pkgrel=2
+pkgver=1.9.2
+pkgrel=1
pkgdesc="Fork of state-threads, patched for SRS"
+_pkgcommit=1d48ef5317f306adb232b440bab11327f9ae3883
arch=('x86_64')
url="https://github.com/ossrs/state-threads/"
license=('GPL2' 'MPL')
makedepends=('git')
-source=("git+https://github.com/ossrs/state-threads/#commit=29472f83ce03bd55770df929e5bd0af99c43988d")
+source=("git+https://github.com/ossrs/state-threads/#commit=${_pkgcommit}")
sha256sums=('SKIP')
build() {
cd "${srcdir}"/state-threads
- make linux-optimized
+ make STATIC_ONLY=no linux-optimized
}
package() {
- cd "${srcdir}"/state-threads/LINUX_*_OPT
+ cd "${srcdir}"/state-threads/obj
install -Dm644 st.h "${pkgdir}"/usr/include/st.h
install -Dm644 libst.a "${pkgdir}"/usr/lib/libst.a
install -Dm755 libst.so.1.9 "${pkgdir}"/usr/lib/libst.so.1.9