summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-01 15:04:12 +0000
committerDaniel Bermond2019-06-01 15:04:12 +0000
commit88f2eebbb122baf82cb38461df9eb711a9d7e4ec (patch)
tree87160aa27e95928902d69fa94f507b85412f6d56
parent833f515b107637b87fa41ad840f5720d4c3c5b85 (diff)
downloadaur-88f2eebbb122baf82cb38461df9eb711a9d7e4ec.tar.gz
Fix license. Use patch for removing insecure rpath.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
-rw-r--r--srt-git-remove-insecure-rpath.patch11
3 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acd769d6d976..4ffb97b5b601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = srt-git
pkgdesc = Secure Reliable Transport - transport technology that optimizes streaming performance across unpredictable networks (git version)
- pkgver = 1.3.1.r45.g4c3dccb
+ pkgver = 1.3.2.r58.g11feba2
pkgrel = 1
url = https://www.srtalliance.org/
- arch = i686
arch = x86_64
- license = MPL
+ license = MPL2
makedepends = git
makedepends = cmake
depends = openssl
provides = srt
conflicts = srt
source = git+https://github.com/Haivision/srt.git
+ source = srt-git-remove-insecure-rpath.patch
sha256sums = SKIP
+ sha256sums = b96008ed593f893b1051191483f9aea0f58703bc6d5074537a6ea740120c0bf6
pkgname = srt-git
diff --git a/PKGBUILD b/PKGBUILD
index 808dab61e965..10bc99ba9d29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,28 @@
pkgname=srt-git
_srcname=srt
-pkgver=1.3.1.r45.g4c3dccb
+pkgver=1.3.2.r58.g11feba2
pkgrel=1
pkgdesc='Secure Reliable Transport - transport technology that optimizes streaming performance across unpredictable networks (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://www.srtalliance.org/'
-license=('MPL')
+license=('MPL2')
depends=('openssl')
makedepends=('git' 'cmake')
provides=('srt')
conflicts=('srt')
-source=('git+https://github.com/Haivision/srt.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Haivision/srt.git'
+ 'srt-git-remove-insecure-rpath.patch')
+sha256sums=('SKIP'
+ 'b96008ed593f893b1051191483f9aea0f58703bc6d5074537a6ea740120c0bf6')
prepare() {
cd "$_srcname"
+ mkdir -p build
+
# remove insecure rpath
- sed -i '/set(FORCE_RPATH/d' CMakeLists.txt
+ patch -Np1 -i "${srcdir}/srt-git-remove-insecure-rpath.patch"
}
pkgver() {
@@ -31,10 +35,7 @@ pkgver() {
}
build() {
- cd "$_srcname"
-
- mkdir -p build
- cd build
+ cd "${_srcname}/build"
cmake \
-DCMAKE_INSTALL_BINDIR:PATH='bin' \
@@ -60,7 +61,4 @@ package() {
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/bin/*-test
-
- # build tries this but fails when DESTDIR is set
- ln -s srt-live-transmit "${pkgdir}/usr/bin/stransmit"
}
diff --git a/srt-git-remove-insecure-rpath.patch b/srt-git-remove-insecure-rpath.patch
new file mode 100644
index 000000000000..34389ed75961
--- /dev/null
+++ b/srt-git-remove-insecure-rpath.patch
@@ -0,0 +1,11 @@
+diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2019-06-01 14:58:09.000000000 +0000
++++ b/CMakeLists.txt 2019-05-31 15:30:35.000000000 +0000
+@@ -706,7 +706,6 @@ macro(srt_make_application name)
+ # be placed into the binrary directory anyway.
+ # XXX not sure about Mac.
+ # See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
+- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
+ endif()
+
+ # We state that Darwin always uses CLANG compiler, which honors this flag the same way.