summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Hruška2019-06-23 09:54:29 +0200
committerOndřej Hruška2019-06-23 09:54:29 +0200
commit6e482963d5a9c92dd7983ed51dda2090a0c35d5d (patch)
treead6bfea06b450c1ed3800eaf06908eed2c8548a1
downloadaur-6e482963d5a9c92dd7983ed51dda2090a0c35d5d.tar.gz
v0.2
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ed578ee9947
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = srtune-git
+ pkgdesc = Fast and lightweight subtitle file manipulator capable of correcting time shift, drift, and cuts. (command line tool)
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://git.ondrovo.com/MightyPork/srtune
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ source = git+https://git.ondrovo.com/MightyPork/srtune.git#tag=0.2
+ md5sums = SKIP
+
+pkgname = srtune-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a28305946717
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+srtune/
+*.tar.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fee0d8cd4390
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Markus Richter <mqus at disroot dot org>
+
+pkgname=srtune-git
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Fast and lightweight subtitle file manipulator capable of correcting time shift, drift, and cuts. (command line tool)"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://git.ondrovo.com/MightyPork/srtune"
+license=('MIT')
+makedepends=('rust' 'cargo' 'git')
+source=("git+https://git.ondrovo.com/MightyPork/srtune.git#tag=0.2")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/srtune"
+ cargo build --release
+}
+
+package() {
+ install -D -m0755 "$srcdir/srtune/target/release/srtune" "$pkgdir/usr/bin/srtune"
+}