summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2012-10-17 16:35:15 +0200
committerMassimiliano Torromeo2012-10-17 16:35:15 +0200
commit742fbc2e46fbdcdf5204823f6a5e227e8a3626e7 (patch)
tree1b13114020b41bead09e07310bee4b89701db728
downloadaur-742fbc2e46fbdcdf5204823f6a5e227e8a3626e7.tar.gz
Implemented packages for HP Proliant administration and diagnostic tools
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..badcdc63581a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hpacucli
+ pkgdesc = HP Command Line Array Configuration Utility
+ pkgver = 9.40_12.0
+ pkgrel = 1
+ url = http://downloads.linux.hp.com/SDR/downloads/mcp
+ arch = i686
+ arch = x86_64
+ groups = hpproliant
+ license = CUSTOM
+ depends = bash
+ source = http://downloads.linux.hp.com/SDR/downloads/mcp/centos/6//current/hpacucli-9.40-12.0..rpm
+ sha256sums = df3bea520c884eee58e4964da08864c949750b2df9b8c974b692b34f5a465ee3
+
+pkgname = hpacucli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e11cc28f15d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=hpacucli
+pkgver=9.10_22.0
+pkgrel=1
+pkgdesc="HP Command Line Array Configuration Utility"
+arch=(i686 x86_64)
+url="http://downloads.linux.hp.com/SDR/downloads/ProLiantSupportPack"
+depends=(bash)
+license=("CUSTOM")
+
+[ $CARCH = "x86_64" ] && depends=(${depends[@]} lib32-gcc-libs)
+
+source=(http://downloads.linux.hp.com/SDR/downloads/ProLiantSupportPack/RedHatEnterpriseServer/6.2/packages/i386/${pkgname}-${pkgver//_/-}.i386.rpm)
+
+package() {
+ cp -a "$srcdir/"* "$pkgdir"
+ rm -f "$pkgdir/"*.rpm
+}
+
+sha256sums=('e398d184932f8a99c0e3edd89f8d601871e5027b86b21984d1a6ef835bcf3c84')
+