summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2019-01-13 10:57:57 -0800
committerChristian Bundy2019-01-13 10:57:57 -0800
commit2b9d9cd14102443bd973eac5b14f3d3bf77a045a (patch)
tree1c6a4a6869e5f03d4dcb61984ea5d2b377866399
parent7de029217f374a9375e32645fe6af71c50946df7 (diff)
downloadaur-2b9d9cd14102443bd973eac5b14f3d3bf77a045a.tar.gz
Release 3.11.4-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rwxr-xr-xrun.sh2
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91c5e6e0ef0a..a082790eed7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ssb-patchwork
pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
pkgver = 3.11.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ssbc/patchwork
arch = i686
arch = x86_64
@@ -17,13 +17,13 @@ pkgbase = ssb-patchwork
depends = gtk2
depends = alsa-lib
depends = nss
- depends = electron
+ depends = electron2
options = !strip
source = https://github.com/ssbc/patchwork/archive/v3.11.4.tar.gz
source = run.sh
source = ssb-patchwork.desktop
sha512sums = 19a0a73b059bed3ff57c10067455bcfd357fa4e56e763814650b7b2cd22f1992d53e9cade5a61ceb03bbbc031c436d7f307038aab0d1f6e7160c5e461709a47d
- sha512sums = 0df1ea65d60742d82ef04bea84376380cad03d3cd4ffb326374578f9f9954ad326b19fc81162ae838c10ae45acdd236c37731b68ca535cbbe7ddf4b69266c33c
+ sha512sums = 582a74d9581c382745b33903f60e40c1fba97a1ff253560fd609ccd133f6074b7827561b559402274e879296b24aad73e2f3f5b9c7f25142e1885de919a2e8b7
sha512sums = 09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6
pkgname = ssb-patchwork
diff --git a/PKGBUILD b/PKGBUILD
index 9e014bb26763..8bb9c6bf261a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=ssb-patchwork
_upstream=patchwork
pkgver=3.11.4
-pkgrel=1
+pkgrel=2
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
license=('AGPL3')
-depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron')
+depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron2')
makedepends=('nodejs' 'npm')
options=(!strip)
source=(
@@ -20,7 +20,7 @@ source=(
sha512sums=(
'19a0a73b059bed3ff57c10067455bcfd357fa4e56e763814650b7b2cd22f1992d53e9cade5a61ceb03bbbc031c436d7f307038aab0d1f6e7160c5e461709a47d'
-'0df1ea65d60742d82ef04bea84376380cad03d3cd4ffb326374578f9f9954ad326b19fc81162ae838c10ae45acdd236c37731b68ca535cbbe7ddf4b69266c33c'
+'582a74d9581c382745b33903f60e40c1fba97a1ff253560fd609ccd133f6074b7827561b559402274e879296b24aad73e2f3f5b9c7f25142e1885de919a2e8b7'
'09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6'
)
@@ -28,9 +28,12 @@ sha512sums=(
build() {
cd "${srcdir}/${_upstream}-${pkgver}"
- npm ci --only=production
- # rm -rf node_modules
- # npm install --only=production
+ npm ci --only=production --ignore-scripts
+ npm rebuild \
+ --runtime=electron \
+ --target=$(electron2 -v) \
+ --abi=$(electron2 --abi) \
+ --disturl=https://atom.io/download/atom-shell
}
package() {
diff --git a/run.sh b/run.sh
index a89d9f61e5e9..3ca71d99165f 100755
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
#!/bin/bash
cd /opt/ssb-patchwork
-exec electron index.js "$@"
+exec electron2 index.js "$@"