summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-08-06 17:27:14 -0700
committerChristian Bundy2018-08-06 17:27:14 -0700
commit68c428254fec67cd7b65028402dc8f4da316f649 (patch)
tree7a73f1bfb7710f05989557ed0dc4a75e71e74bf5
parent076a6629dd597dda25613ac06aa80bf797b9a13b (diff)
downloadaur-68c428254fec67cd7b65028402dc8f4da316f649.tar.gz
Depend on system Electron
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rwxr-xr-xrun.sh2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c936c5f5087b..18a04237ae7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ssb-patchwork
pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
pkgver = 3.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ssbc/patchwork
arch = i686
arch = x86_64
@@ -17,13 +17,14 @@ pkgbase = ssb-patchwork
depends = gtk2
depends = alsa-lib
depends = nss
+ depends = electron
options = !strip
source = https://github.com/ssbc/patchwork/archive/v3.10.1.tar.gz
source = run.sh
source = ssb-patchwork.desktop
- md5sums = 8ecdb2794979e8fbc2b17f7818e44b33
- md5sums = bb315f14e6d7ef57976c8934ddad4fd9
- md5sums = 3c73b5245f2da7dd2e31729e2b57ad37
+ sha512sums = 6694ca9d4f9f265813c94bf84c3931e3214eae75e200c23848ef6fb9992b31e85c905463fc4f8e897aa49ad15c29be9a2485900bd11d68545e48f193236fe423
+ sha512sums = 0df1ea65d60742d82ef04bea84376380cad03d3cd4ffb326374578f9f9954ad326b19fc81162ae838c10ae45acdd236c37731b68ca535cbbe7ddf4b69266c33c
+ sha512sums = 09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6
pkgname = ssb-patchwork
diff --git a/PKGBUILD b/PKGBUILD
index 83e506fefa2d..2db998e8b8e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=ssb-patchwork
_upstream=patchwork
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
license=('AGPL3')
-depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss')
+depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron')
makedepends=('nodejs' 'npm')
options=(!strip)
source=(
@@ -20,14 +20,14 @@ source=(
sha512sums=(
'6694ca9d4f9f265813c94bf84c3931e3214eae75e200c23848ef6fb9992b31e85c905463fc4f8e897aa49ad15c29be9a2485900bd11d68545e48f193236fe423'
-'bbcd812b57fbef59993db18e7ac650013afe671846f7ea7b4908e7e664508a034851b336de2593dad11d871e803e55548896d55468339d91d4d4023ea2fe3b08'
+'0df1ea65d60742d82ef04bea84376380cad03d3cd4ffb326374578f9f9954ad326b19fc81162ae838c10ae45acdd236c37731b68ca535cbbe7ddf4b69266c33c'
'09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6'
)
build() {
cd "${srcdir}/${_upstream}-${pkgver}"
- npm ci
+ npm ci --only=production
}
package() {
diff --git a/run.sh b/run.sh
index e0a253560e4d..a89d9f61e5e9 100755
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
#!/bin/bash
cd /opt/ssb-patchwork
-./node_modules/.bin/electron index.js "$@"
+exec electron index.js "$@"