summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-07-10 12:15:10 -0700
committerChristian Bundy2018-07-10 12:15:10 -0700
commit79bee1c6b29253dc300f65f40645df8d00667b0c (patch)
treee0bc2fe99b2022e77386d7aacd629426f367158c
parent831e112cf61b8b44ea8f3e1a90162f1b587e3aab (diff)
downloadaur-79bee1c6b29253dc300f65f40645df8d00667b0c.tar.gz
Release 3.10.0-1
- Upgrade to Patchwork v3.10.0 - Remove prepare() step - Switch from `npm install` to `npm ci` - Remove electron-rebuild (if necessary we should use `npm run rebuild`)
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9f2ca44355b..78c93524fa78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,27 @@
pkgname=ssb-patchwork
_upstream=patchwork
-pkgver=3.9.0
-pkgrel=3
+pkgver=3.10.0
+pkgrel=1
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
license=('AGPL3')
depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss')
-makedepends=('nodejs-lts-carbon' 'npm')
+makedepends=('nodejs' 'npm')
options=(!strip)
source=(
"https://github.com/ssbc/${_upstream}/archive/v${pkgver}.tar.gz"
'run.sh'
"${pkgname}.desktop"
)
-md5sums=('2036001984b4d904cac87ac452ebfa66'
+md5sums=('2e506b1d70acc8f61cfaed66e8bbeb9f'
'bb315f14e6d7ef57976c8934ddad4fd9'
'3c73b5245f2da7dd2e31729e2b57ad37')
-prepare() {
- cd "${srcdir}/${_upstream}-${pkgver}"
- sed -i'' -e '/postinstall/d' package.json
- sed -i'' -e '/"cross-script"/d' package.json
-}
-
build() {
cd "${srcdir}/${_upstream}-${pkgver}"
- npm install
- npm install electron-rebuild
- ./node_modules/.bin/electron-rebuild
+ npm ci
}
package() {