summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2019-02-13 08:33:42 -0800
committerChristian Bundy2019-02-13 08:33:42 -0800
commitc9a26c5d71ab64c43f111c9f8b0d4a166190b8a3 (patch)
tree0e64ddf07a0345f55d33ff00d94b09c31ef70255
parent2b9d9cd14102443bd973eac5b14f3d3bf77a045a (diff)
downloadaur-c9a26c5d71ab64c43f111c9f8b0d4a166190b8a3.tar.gz
Release 3.11.4-3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a082790eed7d..8f376e812ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ssb-patchwork
pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
pkgver = 3.11.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ssbc/patchwork
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8bb9c6bf261a..0fc4afd3fe11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ssb-patchwork
_upstream=patchwork
pkgver=3.11.4
-pkgrel=2
+pkgrel=3
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
@@ -27,13 +27,17 @@ sha512sums=(
build() {
cd "${srcdir}/${_upstream}-${pkgver}"
+ # Electron's version.
+ export npm_config_target=$(electron2 -v)
+ # The architecture of Electron, can be ia32 or x64.
+ export npm_config_arch=x64
+ export npm_config_target_arch=x64
+ # Download headers for Electron.
+ export npm_config_disturl=https://atom.io/download/electron
+ # Tell node-pre-gyp that we are building for Electron.
+ export npm_config_runtime=electron
- npm ci --only=production --ignore-scripts
- npm rebuild \
- --runtime=electron \
- --target=$(electron2 -v) \
- --abi=$(electron2 --abi) \
- --disturl=https://atom.io/download/atom-shell
+ npm install --only=production --ignore-scripts
}
package() {