summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2019-03-22 10:47:42 -0700
committerChristian Bundy2019-03-22 10:47:42 -0700
commitd075fc32fa525f0620c3e8daa01a9c780bc8b420 (patch)
treeb7fb59f8656923f5350a3b0825721a193f4a5a48
parent72717dc9969ac51860d3b7cda754e88cc4640013 (diff)
downloadaur-d075fc32fa525f0620c3e8daa01a9c780bc8b420.tar.gz
Release 3.11.6-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bee7bddb318a..cc018166344c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ssb-patchwork
pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
- pkgver = 3.11.5
+ pkgver = 3.11.6
pkgrel = 1
url = https://github.com/ssbc/patchwork
arch = i686
@@ -19,10 +19,10 @@ pkgbase = ssb-patchwork
depends = nss
depends = electron2
options = !strip
- source = https://github.com/ssbc/patchwork/archive/v3.11.5.tar.gz
+ source = https://github.com/ssbc/patchwork/archive/v3.11.6.tar.gz
source = run.sh
source = ssb-patchwork.desktop
- sha512sums = 2b412ff3639db2e2511ba2d9db17c7bea27735d90bc07fec4c509e40f164cee6cecce214f1c7f958617cae6b00bbc41c550c560b2921c48104f8fd23f38563ec
+ sha512sums = 1e60b23037f12a11d41965ca04f84baa66082fc439f429d4c011c569e0d2d0f524e8c6e7324b8fadbc621b85b85759049f6a6d87b61a89c030ac5fcda7e7cee4
sha512sums = 582a74d9581c382745b33903f60e40c1fba97a1ff253560fd609ccd133f6074b7827561b559402274e879296b24aad73e2f3f5b9c7f25142e1885de919a2e8b7
sha512sums = 09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6
diff --git a/PKGBUILD b/PKGBUILD
index 97e976035c40..529fbd335dfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ssb-patchwork
_upstream=patchwork
-pkgver=3.11.5
+pkgver=3.11.6
pkgrel=1
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
@@ -19,7 +19,7 @@ source=(
)
sha512sums=(
-'2b412ff3639db2e2511ba2d9db17c7bea27735d90bc07fec4c509e40f164cee6cecce214f1c7f958617cae6b00bbc41c550c560b2921c48104f8fd23f38563ec'
+'1e60b23037f12a11d41965ca04f84baa66082fc439f429d4c011c569e0d2d0f524e8c6e7324b8fadbc621b85b85759049f6a6d87b61a89c030ac5fcda7e7cee4'
'582a74d9581c382745b33903f60e40c1fba97a1ff253560fd609ccd133f6074b7827561b559402274e879296b24aad73e2f3f5b9c7f25142e1885de919a2e8b7'
'09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6'
)
@@ -27,6 +27,11 @@ sha512sums=(
build() {
cd "${srcdir}/${_upstream}-${pkgver}"
+
+ # Remove postinstall script that references `electron`
+ # (we instead need it to reference `electron2`)
+ sed -i '/postinstall/d' package.json
+
# Electron's version.
export npm_config_target=$(electron2 -v)
# The architecture of Electron, can be ia32 or x64.
@@ -36,9 +41,10 @@ build() {
export npm_config_disturl=https://atom.io/download/electron
# Tell node-pre-gyp that we are building for Electron.
export npm_config_runtime=electron
-
- npm install --only=production --ignore-scripts
- npm rebuild
+ # Tell node-pre-gyp to build module from source code.
+ export npm_config_build_from_source=true
+ # Install all dependencies, and store cache to ~/.electron-gyp.
+ HOME=~/.electron-gyp npm install --only=production
}
package() {