summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorubone2017-04-23 12:13:50 +0300
committerubone2017-04-23 12:13:50 +0300
commit88a3c274622928759c868e4394fa5853ad781203 (patch)
tree8c8ad83b410b78bca1ffd9f53769144b86655ddb
downloadaur-88a3c274622928759c868e4394fa5853ad781203.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea1e6c9c0a6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sselp
+ pkgdesc = Simple X selection printer. Prints the X selection to stdout.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://tools.suckless.org/x/sselp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ source = http://dl.suckless.org/tools/sselp-0.2.tar.gz
+ md5sums = b74d6558790d8df897db40bca90bc0f6
+
+pkgname = sselp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2d0732d3c9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: ubone <vns at $thisdistro dot net>
+pkgname=sselp
+pkgver=0.2
+pkgrel=1
+pkgdesc="Simple X selection printer. Prints the X selection to stdout."
+arch=('i686' 'x86_64')
+url="http://tools.suckless.org/x/sselp"
+license=('MIT')
+depends=('libx11')
+source=(http://dl.suckless.org/tools/sselp-$pkgver.tar.gz)
+md5sums=('b74d6558790d8df897db40bca90bc0f6')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+ install -m644 -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -m644 -D README $pkgdir/usr/share/doc/$pkgname/README
+} \ No newline at end of file