summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Arthur Long2021-08-02 23:54:27 +0800
committerMichael Arthur Long2021-08-02 23:54:32 +0800
commit388506d80b9fea268058c2689014f06c57655bd7 (patch)
treef26888e8cca1d5c81c62cbaf2c9c02d063ed0987
downloadaur-388506d80b9fea268058c2689014f06c57655bd7.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5e0bed47ea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ssh-rdp-git
+ pkgdesc = Real display ssh based remote desktop. No relation to Microsoft's remote desktop protocol.
+ pkgver = r100.fd0db21
+ pkgrel = 1
+ url = https://github.com/kokoko3k/ssh-rdp
+ arch = any
+ license = LGPL3
+ depends = bash
+ depends = ffmpeg
+ depends = openssh
+ depends = netevent-git
+ depends = inotify-tools
+ depends = wmctrl
+ depends = mpv
+ depends = util-linux
+ optdepends = ssh-rdp-host-git: udev rules and dependencies for the host
+ provides = ssh-rdp
+ conflicts = ssh-rdp
+ source = git+https://github.com/kokoko3k/ssh-rdp.git
+ sha256sums = SKIP
+
+pkgname = ssh-rdp-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35f8b590fe5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Arthur Long <adhaxclient at hotmail dot com>
+
+_pkgname=ssh-rdp
+pkgname=${_pkgname}-git
+pkgver=r100.fd0db21
+pkgrel=1
+pkgdesc="Real display ssh based remote desktop. No relation to Microsoft's remote desktop protocol."
+arch=('any')
+url='https://github.com/kokoko3k/ssh-rdp'
+license=('LGPL3')
+depends=('bash' 'ffmpeg' 'openssh' 'netevent-git' 'inotify-tools' 'wmctrl' 'mpv' 'util-linux')
+optdepends=('ssh-rdp-host-git: udev rules and dependencies for the host')
+provides=('ssh-rdp')
+conflicts=('ssh-rdp')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/ssh-rdp.sh" "$pkgdir/usr/bin/ssh-rdp.sh"
+}