summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Arthur Long2021-08-02 23:54:39 +0800
committerMichael Arthur Long2021-08-02 23:54:45 +0800
commit15b86e2f9b786153fd513977d153da14f788e8ca (patch)
tree60ef86948d02a3077236e73b334db7b890b26c3d
downloadaur-15b86e2f9b786153fd513977d153da14f788e8ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d94e84fed551
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ssh-rdp-host-git
+ pkgdesc = Udev rules and dependencies for an ssh-rdp host
+ pkgver = r100.fd0db21
+ pkgrel = 1
+ url = https://github.com/kokoko3k/ssh-rdp
+ arch = any
+ license = LGPL3
+ depends = bash
+ depends = ffmpeg
+ depends = openssh
+ depends = netevent-git
+ depends = xorg-xdpyinfo
+ depends = pulseaudio
+ optdepends = ssh-rdp-git: bash script used on clients to connect
+ provides = ssh-rdp-host
+ conflicts = ssh-rdp-host
+ source = git+https://github.com/kokoko3k/ssh-rdp.git
+ sha256sums = SKIP
+
+pkgname = ssh-rdp-host-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3732f15b07db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Arthur Long <adhaxclient at hotmail dot com>
+
+_pkgname=ssh-rdp
+pkgname=${_pkgname}-host-git
+pkgver=r100.fd0db21
+pkgrel=1
+pkgdesc='Udev rules and dependencies for an ssh-rdp host'
+arch=('any')
+url='https://github.com/kokoko3k/ssh-rdp'
+license=('LGPL3')
+depends=('bash' 'ffmpeg' 'openssh' 'netevent-git' 'xorg-xdpyinfo' 'pulseaudio')
+optdepends=('ssh-rdp-git: bash script used on clients to connect')
+provides=('ssh-rdp-host')
+conflicts=('ssh-rdp-host')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm644 "$srcdir/$_pkgname/70-uinput.rules" "$pkgdir/etc/udev/rules.d/70-ssh-rdp-uinput.rules"
+}