summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE2021-10-25 15:17:17 +0200
committerFabien LEFEBVRE2021-10-25 15:17:17 +0200
commit422d2f0ef433c7ba9704cf07a2b8c80928057b59 (patch)
treeb52b254a75e9bd06cf05815dfc8f9652743c256e
parentc60449936e972bcf56a3612f8a5c8b3320c5473f (diff)
downloadaur-422d2f0ef433c7ba9704cf07a2b8c80928057b59.tar.gz
upgpkg: sshcommand 0.14.1-2
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2b540a0a00b..756b90196d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sshcommand
pkgdesc = Turn SSH into a thin client specifically for your app
pkgver = 0.14.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dokku/sshcommand
arch = x86_64
license = MIT
diff --git a/.gitignore b/.gitignore
index 188ec71be277..f9ecc0a87e76 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-src/
-pkg/
-*.tar.gz
-*.tgz
+/src/
+/pkg/
+/*.tgz
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index a757d4553871..cf6f46e5ce25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
pkgname=sshcommand
pkgver=0.14.1
-pkgrel=1
+pkgrel=2
pkgdesc='Turn SSH into a thin client specifically for your app'
arch=('x86_64')
url='https://github.com/dokku/sshcommand'
license=('MIT')
-
-source=("https://github.com/dokku/sshcommand/releases/download/v${pkgver}/sshcommand_${pkgver}_linux_x86_64.tgz"
+source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_x86_64.tgz"
'LICENSE')
sha256sums=('c4560f02b3217ce7a7c9faa912fee4b0c66bfc83ca5603760110bb82dc6f98aa'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
package() {
- install -Dm755 sshcommand "${pkgdir}/usr/bin/sshcommand"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/sshcommand/LICENSE"
+ cd "${srcdir}"
+
+ install -Dm755 sshcommand "${pkgdir}/usr/bin/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}