summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-17 11:47:20 +0200
committerDimitris Kiziridis2020-03-17 11:47:20 +0200
commit549f6c9f2dd8ed64f1f6459aa3a8ba8d31ea526c (patch)
tree3cd30e7c40c6bc6bce102a3eeb1346169019f41b
downloadaur-549f6c9f2dd8ed64f1f6459aa3a8ba8d31ea526c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1661deec08cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sshesame-git
+ pkgdesc = A fake SSH server that lets everyone in and logs their activity
+ pkgver = r23.b74f93f
+ pkgrel = 1
+ url = https://github.com/jaksi/sshesame
+ arch = x86_64
+ license = Apache2
+ makedepends = go
+ source = git+https://github.com/jaksi/sshesame
+ md5sums = SKIP
+
+pkgname = sshesame-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1b4747adef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=sshesame-git
+pkgver=r23.b74f93f
+pkgrel=1
+pkgdesc="A fake SSH server that lets everyone in and logs their activity"
+arch=('x86_64')
+url='https://github.com/jaksi/sshesame'
+license=('Apache2')
+makedepends=('go')
+source=("git+https://github.com/jaksi/sshesame")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/sshesame"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/sshesame"
+ mkdir -p $srcdir/go
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go get -d -v ./...
+ go build -v -o sshesame-bin
+}
+
+package() {
+ cd "${srcdir}/sshesame"
+ install -Dm755 sshesame-bin "${pkgdir}/usr/bin/sshesame"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/sshesame/LICENSE"
+} \ No newline at end of file