summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 12:08:58 +1000
committerPhillip Smith2015-06-02 12:08:58 +1000
commitdf89b77e8ba0413dbf0209e63567fdf1d301bcba (patch)
treedcf53d6e59ad40d018b9c4968767350d1928508c
downloadaur-df89b77e8ba0413dbf0209e63567fdf1d301bcba.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f5ec06109b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sshfp
+ pkgdesc = Generates DNS SSHFP-type records from SSH public keys from public keys from a known_hosts file or from scanning the host's sshd daemon.
+ pkgver = 1.2.2
+ pkgrel = 2
+ url = http://www.xelerance.com/software/sshfp/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = python2-dnspython
+ source = sshfp-1.2.2.tar.gz::https://github.com/xelerance/sshfp/archive/1.2.2.tar.gz
+ md5sums = ebf3abb952ffa90914913ef2060ac125
+
+pkgname = sshfp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2ff06054ab6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/sshfp-*.pkg.tar.xz
+/sshfp-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c1a33353b46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=sshfp
+pkgver=1.2.2
+pkgrel=2
+pkgdesc="Generates DNS SSHFP-type records from SSH public keys from public keys from a known_hosts file or from scanning the host's sshd daemon."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('python2' 'python2-dnspython')
+url="http://www.xelerance.com/software/sshfp/"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/xelerance/$pkgname/archive/${pkgver}.tar.gz")
+md5sums=('3cedcc3463e72196ee2028543d03ebfc')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver/
+
+ # use python2 instead of python
+ sed -e 's|python |python2 |g' \
+ -i "$srcdir"/$pkgname-$pkgver/Makefile
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver/
+
+ make DESTDIR="$pkgdir" install
+
+ sed -e 's|^#!/usr/bin/python$|#!/usr/bin/python2|g' \
+ -i "$pkgdir"/usr/bin/sshfp \
+ -i "$pkgdir"/usr/bin/dane
+}
+
+# vim:set ts=2 sw=2 et: