summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Matt2019-01-23 22:16:04 +0100
committerLukas Matt2019-01-23 22:16:04 +0100
commitd5598844728b68e616f844e087465d8f07446c50 (patch)
tree355065f66cd5593dc18c3bcc2541ee35188e57ed
downloadaur-d5598844728b68e616f844e087465d8f07446c50.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f24ffc26cc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sshfsmux
+ pkgdesc = Multiplexer client based on the Secure Shell FileSystem
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://code.google.com/archive/p/sshfsmux/
+ arch = x86_64
+ license = GPL
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sshfsmux/sshfsmux-1.2.tar.gz
+ validpgpkeys = 1E9E2C1BCF7639B219FBE159903A00FC06CC137B
+ md5sums = 7aaaa74c2b7d06266ed3c25bc5971b28
+
+pkgname = sshfsmux
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..70718af0f89b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+sshfsmux-*.tar.xz
+sshfsmux-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ae3b9d6ed3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Lukas Matt <lukas@matt.wf>
+pkgname=sshfsmux
+pkgver=1.2
+pkgrel=1
+epoch=
+pkgdesc="Multiplexer client based on the Secure Shell FileSystem"
+arch=('x86_64')
+url="https://code.google.com/archive/p/sshfsmux/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sshfsmux/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('7aaaa74c2b7d06266ed3c25bc5971b28')
+validpgpkeys=('1E9E2C1BCF7639B219FBE159903A00FC06CC137B')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}