summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-12-22 19:27:24 +0800
committerChocobo12021-12-22 19:27:24 +0800
commit9efbf7ab312eda275e7ff2dc13a0878acfd4c35c (patch)
treecab2571c8254ea3ff20084a859617dda71ae7c81
downloadaur-9efbf7ab312eda275e7ff2dc13a0878acfd4c35c.tar.gz
newpkg: sshpass-svn r77-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6edf4152cf10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sshpass-svn
+ pkgdesc = A tool for non-interactivly performing password authentication
+ pkgver = r77
+ pkgrel = 1
+ url = https://sourceforge.net/projects/sshpass/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ depends = glibc
+ depends = openssh
+ provides = sshpass
+ conflicts = sshpass
+ options = staticlibs
+ source = svn+https://svn.code.sf.net/p/sshpass/code/trunk
+ sha256sums = SKIP
+
+pkgname = sshpass-svn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..467a28746e66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=sshpass-svn
+pkgver=r77
+pkgrel=1
+pkgdesc="A tool for non-interactivly performing password authentication"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/sshpass/"
+license=('GPL')
+depends=('glibc' 'openssh')
+makedepends=('subversion')
+provides=('sshpass')
+conflicts=('sshpass')
+options=('staticlibs')
+source=("svn+https://svn.code.sf.net/p/sshpass/code/trunk")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "trunk"
+
+ _ver="$(svnversion)"
+ printf "r%s" "${_ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "trunk"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "trunk"
+
+ #make check
+}
+
+package() {
+ cd "trunk"
+
+ make DESTDIR="$pkgdir" install
+}