summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-08-16 17:29:08 +0100
committerHans-Nikolai Viessmann2016-08-16 17:29:08 +0100
commit13a90d7a3c4bf4f0d24b8df6cefb37d713209a50 (patch)
tree9f4fd8419bbcc890739995e53da253186e8e7d99
parent9871d9a2b506613d65ce18c4e204334feaeb5ddb (diff)
downloadaur-13a90d7a3c4bf4f0d24b8df6cefb37d713209a50.tar.gz
Moved to Perl
This is a fairly major change. More info in PERL_README.md in the upstream repo.
-rw-r--r--.SRCINFO14
-rw-r--r--CHANGELOG.md29
-rw-r--r--PKGBUILD38
-rw-r--r--sshprint.install10
4 files changed, 68 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d01f0ed30bc..cba1e43a3d5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = sshprint
- pkgdesc = A ZSH script to print local files on remote printers using SSH
- pkgver = 1.6.3
+ pkgdesc = A Perl script to print local files on remote printers using SSH
+ pkgver = 2.01
pkgrel = 1
url = https://github.com/hv15/sshprint
install = sshprint.install
- changelog = CHANGELOG.md
arch = any
license = MIT
+ depends = perl>=5.22.0
depends = openssh
- depends = zsh
- depends = gawk
- source = https://github.com/hv15/sshprint/archive/1.6.3-beta.tar.gz
- md5sums = 4435f2d92d1cd18d4d7388918535fd78
+ conflicts = sshprint<=1.6.3
+ options = !emptydirs
+ source = https://github.com/hv15/sshprint/archive/2.01.tar.gz
+ md5sums = f5d27a644fa205d426a25bd65c007537
pkgname = sshprint
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 850bdc534abd..3de9a61729d5 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,11 +1,36 @@
# Change Log
## [Unreleased]
-Currently nothing in the pipes...
+Nothing to report...
+
+## [2.01] - 2016.08.16
+### **Fixes**
+- Forgot module in `sshprint` script
+
+## [2.00] - 2016.08.16
+### **Major Changes**
+- Moved from ZSH to Perl (see PERL_README.md for why)
+ - because of this, users are advised to remove the previous version of
+ `sshprint`.
+- Version number changed from semantic version to Perl's versioning convention
+ - Dropped the `beta' postfix from the version number
+- Started using some modules, like Config::Simple and Net::OpenSSH to deal with
+ accessing configurations and handling SSH connections respectively.
+
+### **Known Problems**
+- Currently untested (there are likely to be teething problems)
+
+### **Still to do**
+- PERL opens up the possibility for better cohesion of subroutines and a bit of
+ OOP as well. What this means is that I can drop most of my global variables
+ and stick to loosely coupled functions. My intent is to create a script for
+ use with the CUPS server directly.
## [1.6.3] - 2016.06.28
### Fixed
- Fix regex in select printer dialog.
-[Unreleased]: https://github.com/hv15/sshprint/compare/1.6.3-beta...HEAD
+[Unreleased]: https://github.com/hv15/sshprint/compare/2.00...HEAD
+[2.01]: https://github.com/hv15/sshprint/compare/2.00...2.01
+[2.00]: https://github.com/hv15/sshprint/compare/1.6.3-beta...2.00
[1.6.3]: https://github.com/hv15/sshprint/compare/1.6.2-beta...1.6.3-beta
diff --git a/PKGBUILD b/PKGBUILD
index 3dc16a89274a..f7e7bd8acb81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,29 @@
-# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
-pkgname=sshprint
-pkgver=1.6.3
+# Maintainer: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
+_project=sshprint
+pkgname=$_project
+pkgver=2.01
pkgrel=1
-_pkgrel=beta
-pkgdesc="A ZSH script to print local files on remote printers using SSH"
+pkgdesc="A Perl script to print local files on remote printers using SSH"
arch=('any')
-url="https://github.com/hv15/sshprint"
+url="https://github.com/hv15/$_project"
license=('MIT')
-changelog='CHANGELOG.md'
+depends=('perl>=5.22.0' 'openssh')
+conflicts=('sshprint<=1.6.3')
+options=(!emptydirs)
install=sshprint.install
-depends=('openssh' 'zsh' 'gawk')
-source=("https://github.com/hv15/sshprint/archive/${pkgver}-${_pkgrel}.tar.gz")
-md5sums=('4435f2d92d1cd18d4d7388918535fd78')
+source=("https://github.com/hv15/${_project}/archive/${pkgver}.tar.gz")
+md5sums=('f5d27a644fa205d426a25bd65c007537')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+
+ perl Build.PL installdirs=vendor destdir="$pkgdir/"
+ perl Build
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}-${_pkgrel}"
+ cd "$srcdir/${pkgname}-$pkgver"
+
# place the doc
install -d "${pkgdir}/usr/share/doc/sshprint"
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/sshprint/README"
@@ -22,7 +31,8 @@ package() {
install -Dm644 "config.examples/server_config.example" "${pkgdir}/usr/share/doc/sshprint/server_config.example"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # place the script
- install -Dm755 "sshprint" "${pkgdir}/usr/bin/sshprint"
+ # place Perl script and module
+ perl Build install
}
-# vim:ts=2 sw=2
+
+# vim:set ts=2 sw=2 et:
diff --git a/sshprint.install b/sshprint.install
index 292f2342a4c4..aa65b20869cd 100644
--- a/sshprint.install
+++ b/sshprint.install
@@ -1,7 +1,17 @@
# Maintainer: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
+pre_install() {
+ echo "!!! This is a major revision and critically how the config"
+ echo "!!! files are handled has changed. Please check the man page"
+ echo "!!! of sshprint.config for more information."
+}
+
post_install() {
echo ">>> Remember to create your config files for \`sshprint'"
echo ">>> They are meant to be located in \$HOME/.config/sshprint/"
echo ">>> Examples can be found under /usr/share/doc/sshprint/ or"
echo ">>> online at https://github.com/hv15/sshprint."
}
+
+post_upgrade() {
+ post_install
+}