summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2015-06-08 11:27:52 +0100
committerHans-Nikolai Viessmann2015-06-08 11:27:52 +0100
commit45498bdda166412e49a5acf214065f5d44d7d93a (patch)
tree9f8550ff6226f63a5805f4f3203c5325c18f5d17
downloadaur-45498bdda166412e49a5acf214065f5d44d7d93a.tar.gz
Updating for migration AUR4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--sshprint.install7
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bae8dbd388b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sshprint
+ pkgdesc = A ZSH script to print local files on remote printers using SSH
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/hv15/sshprint
+ install = sshprint.install
+ arch = any
+ license = MIT
+ depends = openssh
+ depends = zsh
+ depends = gawk
+ source = https://github.com/hv15/sshprint/archive/1.6.2-beta.tar.gz
+ md5sums = 7516b88549057ef577ae7904e3328e46
+
+pkgname = sshprint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d98f9eb162af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 at hw.ac.uk>
+pkgname=sshprint
+pkgver=1.6.2
+_pkgrel=beta
+pkgrel=1
+pkgdesc="A ZSH script to print local files on remote printers using SSH"
+arch=('any')
+url="https://github.com/hv15/sshprint"
+license=('MIT')
+install=sshprint.install
+depends=('openssh' 'zsh' 'gawk')
+source=("https://github.com/hv15/sshprint/archive/${pkgver}-${_pkgrel}.tar.gz")
+md5sums=('7516b88549057ef577ae7904e3328e46')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}-${_pkgrel}"
+ # place the doc
+ install -d "${pkgdir}/usr/share/doc/sshprint"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/sshprint/README"
+ install -Dm644 "config.examples/config.example" "${pkgdir}/usr/share/doc/sshprint/config.example"
+ install -Dm644 "config.examples/server_config.example" "${pkgdir}/usr/share/doc/sshprint/server_config.example"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # place the script
+ install -Dm755 "sshprint" "${pkgdir}/usr/bin/sshprint"
+}
diff --git a/sshprint.install b/sshprint.install
new file mode 100644
index 000000000000..292f2342a4c4
--- /dev/null
+++ b/sshprint.install
@@ -0,0 +1,7 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
+post_install() {
+ echo ">>> Remember to create your config files for \`sshprint'"
+ echo ">>> They are meant to be located in \$HOME/.config/sshprint/"
+ echo ">>> Examples can be found under /usr/share/doc/sshprint/ or"
+ echo ">>> online at https://github.com/hv15/sshprint."
+}