summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-10-09 12:18:15 +0100
committerHans-Nikolai Viessmann2016-10-09 12:18:15 +0100
commit844d995520645d67966681a51df21276c0fa960e (patch)
tree89e9eac24f9ff121fbf46bfc67888391d71bf81c
parent65ddba6e1eac241a6a5c1665aa7b1b2be0adb68d (diff)
downloadaur-844d995520645d67966681a51df21276c0fa960e.tar.gz
Updated to 2.05
This includes a minor fix to commandline parsing...
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md7
-rw-r--r--PKGBUILD6
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4141f76e6423..48e268a5ee79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sshprint
pkgdesc = A Perl script to print local files on remote printers using SSH
- pkgver = 2.04
+ pkgver = 2.05
pkgrel = 1
url = https://github.com/hv15/sshprint
install = sshprint.install
@@ -14,8 +14,8 @@ pkgbase = sshprint
depends = perl-net-openssh
conflicts = sshprint<=1.6.3
options = !emptydirs
- source = https://github.com/hv15/sshprint/archive/2.04.tar.gz
- md5sums = 8790659a28cb4e64fc16b860f3e6e38f
+ source = https://github.com/hv15/sshprint/archive/2.05.tar.gz
+ md5sums = 07134492f0c488e4c044a46d7274c891
pkgname = sshprint
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c3662732310f..fb0f7bdb27e3 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,6 +3,10 @@
## [Unreleased]
Nothing to report...
+## [2.05] - 2016.10.09
+### **Fixes**
+- Fixed incorrect parameter check for printer from the commandline
+
## [2.04] - 2016.08.23
### **Fixes**
- Added more checks to sshprint commandline arguments
@@ -52,7 +56,8 @@ Nothing to report...
### Fixed
- Fix regex in select printer dialog.
-[Unreleased]: https://github.com/hv15/sshprint/compare/2.04...HEAD
+[Unreleased]: https://github.com/hv15/sshprint/compare/2.05...HEAD
+[2.05]: https://github.com/hv15/sshprint/compare/2.04...2.05
[2.04]: https://github.com/hv15/sshprint/compare/2.03...2.04
[2.03]: https://github.com/hv15/sshprint/compare/2.02...2.03
[2.02]: https://github.com/hv15/sshprint/compare/2.01...2.02
diff --git a/PKGBUILD b/PKGBUILD
index 1b53bde2d368..46c41413f861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
_project=sshprint
pkgname=$_project
-pkgver=2.04
+pkgver=2.05
pkgrel=1
pkgdesc="A Perl script to print local files on remote printers using SSH"
arch=('any')
@@ -13,7 +13,7 @@ options=(!emptydirs)
changelog='CHANGELOG.md'
install=sshprint.install
source=("https://github.com/hv15/${_project}/archive/${pkgver}.tar.gz")
-md5sums=('8790659a28cb4e64fc16b860f3e6e38f')
+md5sums=('07134492f0c488e4c044a46d7274c891')
build() {
cd "$srcdir/${pkgname}-$pkgver"
@@ -26,6 +26,7 @@ package() {
cd "$srcdir/${pkgname}-$pkgver"
# place the doc
+ msg2 "Installing documentations"
install -d "${pkgdir}/usr/share/doc/sshprint"
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/sshprint/README"
install -Dm644 "config.examples/config.example" "${pkgdir}/usr/share/doc/sshprint/config.example"
@@ -33,6 +34,7 @@ package() {
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# place Perl script and module
+ msg2 "Installing library and binary"
perl Build install
}