summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Down2016-05-10 14:11:58 -0700
committerChris Down2016-05-10 14:11:58 -0700
commit7bfef045af505bc65f291b5c30dad019ba1c97c2 (patch)
tree01b66c021cdf4a9c315b1cfda4ca602103737eec
downloadaur-7bfef045af505bc65f291b5c30dad019ba1c97c2.tar.gz
Release 0.6.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24f70810b57b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue May 10 21:11:50 UTC 2016
+pkgbase = sshrc
+ pkgdesc = Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/Russell91/sshrc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = openssh
+ conflicts = sshrc-git
+ source = https://github.com/Russell91/sshrc/archive/0.6.1.zip
+ md5sums = 8a72d40d23d4550a11274c680c5f1838
+
+pkgname = sshrc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92bdd2c4316e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Chris Down <chris@chrisdown.name>
+
+pkgname=sshrc
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box."
+arch=('any')
+url="https://github.com/Russell91/sshrc"
+license=('MIT')
+depends=('openssh')
+makedepends=('git')
+source=("https://github.com/Russell91/sshrc/archive/${pkgver}.zip")
+md5sums=('8a72d40d23d4550a11274c680c5f1838')
+conflicts=(sshrc-git)
+
+package() {
+ cd "${srcdir?}/$pkgname-$pkgver" || return 1
+ install -Dm 0755 sshrc "${pkgdir?}/usr/bin/sshrc"
+ install -Dm 0755 moshrc "${pkgdir?}/usr/bin/moshrc"
+ install -Dm 0644 LICENSE "${pkgdir?}/usr/share/licenses/$pkgname/LICENSE"
+}