summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:14:27 +0300
committerAchilleas Pipinellis2015-06-10 09:14:27 +0300
commitf9fadeccffffdb7d4af2f2621edbd42191449076 (patch)
tree61ea8112297246151d0c0486d1602f948efc9b01
downloadaur-f9fadeccffffdb7d4af2f2621edbd42191449076.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ef2129f7e1e8
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = sshrc-git
+ pkgdesc = Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box.
+ pkgver = 20140919
+ pkgrel = 1
+ url = https://github.com/Russell91/sshrc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = openssh
+ source = git://github.com/Russell91/sshrc.git
+
+pkgname = sshrc-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..471bffcd22bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sshrc-git
+ pkgdesc = Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box.
+ pkgver = 20140919
+ pkgrel = 1
+ url = https://github.com/Russell91/sshrc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = openssh
+ source = git://github.com/Russell91/sshrc.git
+ md5sums = SKIP
+
+pkgname = sshrc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eef53542a54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Achilleas Pipinellis <axilleas@archlinux.info>
+pkgname=sshrc-git
+pkgver=20140919
+pkgrel=1
+pkgdesc="Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box."
+arch=('any')
+url="https://github.com/Russell91/sshrc"
+license=('MIT')
+depends=('openssh')
+makedepends=('git')
+source=("git://github.com/Russell91/sshrc.git")
+md5sums=('SKIP')
+
+_gitname="sshrc"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm 0755 sshrc "$pkgdir/usr/bin/sshrc"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+}