summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Simons2015-09-11 14:43:16 +0200
committerDave Simons2015-09-11 14:51:00 +0200
commit6f99c938083669b69e9f31e180749f5cf563894d (patch)
treeaa42e4f95f47476de994c7e7a5e5e3fa6836932a
parentc76e12d8786f59690a1c9a3d76a2b48261ba9164 (diff)
downloadaur-6f99c938083669b69e9f31e180749f5cf563894d.tar.gz
fix ordering in nf-cleanup script
Signed-off-by: Dave Simons <pkgs@simonsd.org>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xnf-cleanup8
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ae649b3af59..7c8afcacc847 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sshttp-git
pkgdesc = SSH/HTTP(S) multiplexer
pkgver = e145de8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/stealth/sshttp
arch = any
license = BSD
@@ -16,7 +16,7 @@ pkgbase = sshttp-git
source = sshttpd.config
source = sshttpd.service
md5sums = SKIP
- md5sums = 7c75787f5b74ad1922fdf6722b1c7405
+ md5sums = 22d5c47059ba77d09812106800939d57
md5sums = 6d35b4409cac3ebd6e75f4736805f102
md5sums = cff8825c1428b87836218af0ed8a0066
diff --git a/PKGBUILD b/PKGBUILD
index f8517b4badfc..93e7366ff331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=sshttp-git
pkgver=e145de8
-pkgrel=2
+pkgrel=3
pkgdesc="SSH/HTTP(S) multiplexer"
arch=('any')
url="https://github.com/stealth/sshttp"
@@ -16,7 +16,7 @@ source=('git://github.com/stealth/sshttp'
'sshttpd.config'
'sshttpd.service')
md5sums=('SKIP'
- '7c75787f5b74ad1922fdf6722b1c7405'
+ '22d5c47059ba77d09812106800939d57'
'6d35b4409cac3ebd6e75f4736805f102'
'cff8825c1428b87836218af0ed8a0066')
diff --git a/nf-cleanup b/nf-cleanup
index 0762308e8d21..b37c745ac894 100755
--- a/nf-cleanup
+++ b/nf-cleanup
@@ -20,14 +20,14 @@ HTTP_PORT=8080
iptables -D INPUT -i $DEV -p tcp --dport $SSH_PORT -j DROP
iptables -D INPUT -i $DEV -p tcp --dport $HTTP_PORT -j DROP
-iptables -t mangle -D DIVERT -j MARK --set-mark 1
-iptables -t mangle -D DIVERT -j ACCEPT
-
-iptables -t mangle -X DIVERT || true
iptables -t mangle -D OUTPUT -p tcp -o $DEV --sport $SSH_PORT -j DIVERT
iptables -t mangle -D OUTPUT -p tcp -o $DEV --sport $HTTP_PORT -j DIVERT
iptables -t mangle -D PREROUTING -p tcp -m socket -j DIVERT
+iptables -t mangle -D DIVERT -j MARK --set-mark 1
+iptables -t mangle -D DIVERT -j ACCEPT
+iptables -t mangle -X DIVERT || true
+
ip rule del fwmark 1 lookup 123 || true
ip route del local 0.0.0.0/0 dev lo table 123