summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-03-11 14:48:50 +0100
committerwillemw122016-03-11 14:50:44 +0100
commit471c71d2fff36e85a6deda8aa23bf13e0db5657d (patch)
tree0727c2cb5c0797dbd50fda6e2c069099e0311510
parenta8a4b29621b959635ee333533bb2b3a905918581 (diff)
downloadaur-471c71d2fff36e85a6deda8aa23bf13e0db5657d.tar.gz
Patch: replace "$DAEMON_OPTS" by "-F/etc/sslh.conf" in the service file.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91b477eb509c..fe5d36da1fdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Mar 11 13:11:31 UTC 2016
+# Fri Mar 11 13:44:39 UTC 2016
pkgbase = sslh-git
pkgdesc = Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port
pkgver = 1.17.r38.g8f39c10
diff --git a/PKGBUILD b/PKGBUILD
index 45fcdd48352c..d743460af583 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,11 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ sed -i 's|^\(ExecStart.*\) $DAEMON_OPTS|\1 -F/etc/sslh.conf|' scripts/systemd.sslh.service
+}
+
build() {
cd $pkgname
make VERSION=\"v$pkgver\" USELIBCAP=1 USELIBCONFIG=1 USESYSTEMD=1