summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-12-03 09:38:34 +0100
committerwillemw122016-12-03 09:38:34 +0100
commit7b3075c372be7fea5788cebffacfbf5e3e674434 (patch)
treed50cbc01bb0e02b8eb6f5b5fb4d450e5f719e2e2
parent471c71d2fff36e85a6deda8aa23bf13e0db5657d (diff)
downloadaur-7b3075c372be7fea5788cebffacfbf5e3e674434.tar.gz
Enable libwrap. Disable libcap.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe5d36da1fdc..4685319808d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Mar 11 13:44:39 UTC 2016
pkgbase = sslh-git
pkgdesc = Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port
- pkgver = 1.17.r38.g8f39c10
+ pkgver = 1.18.r9.gf02ce38
pkgrel = 1
url = http://www.rutschle.net/tech/sslh.shtml
arch = i686
arch = x86_64
license = GPL2
makedepends = git
- depends = libcap
depends = libconfig
+ depends = libwrap
depends = systemd
provides = sslh
conflicts = sslh
diff --git a/PKGBUILD b/PKGBUILD
index d743460af583..443fa4c61e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
_pkgname=sslh
pkgname=$_pkgname-git
-pkgver=1.17.r38.g8f39c10
+pkgver=1.18.r9.gf02ce38
pkgrel=1
pkgdesc="Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port"
arch=('i686' 'x86_64')
url='http://www.rutschle.net/tech/sslh.shtml'
license=('GPL2')
-depends=('libcap' 'libconfig' 'systemd')
+#depends=('libcap' 'libconfig' 'libwrap' 'systemd')
+depends=('libconfig' 'libwrap' 'systemd')
makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname)
@@ -32,15 +33,17 @@ prepare() {
build() {
cd $pkgname
- make VERSION=\"v$pkgver\" USELIBCAP=1 USELIBCONFIG=1 USESYSTEMD=1
+ #make VERSION=\"v$pkgver\" USELIBCAP=1 USELIBCONFIG=1 USELIBWRAP=1 USESYSTEMD=1
+ make VERSION=\"v$pkgver\" USELIBCAP= USELIBCONFIG=1 USELIBWRAP=1 USESYSTEMD=1
}
package() {
- # Default Arch Linux config
+ # Default config
install -Dm644 sslh.conf "$pkgdir/etc/sslh.conf"
# Systemd
install -Dm644 sslh.sysusers "$pkgdir/usr/lib/sysusers.d/sslh.conf"
+
cd $pkgname
install -Dm644 scripts/etc.sysconfig.sslh "$pkgdir/etc/conf.d/sslh"
install -Dm644 scripts/systemd.sslh.service "$pkgdir/usr/lib/systemd/system/sslh.service"
@@ -56,7 +59,5 @@ package() {
# Examples
install -Dm644 basic.cfg "$pkgdir/usr/share/doc/$pkgname/basic.cfg"
install -Dm644 example.cfg "$pkgdir/usr/share/doc/$pkgname/example.cfg"
-
}
-# vim:set ts=2 sw=2 et: