summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-03-11 14:18:56 +0100
committerwillemw122016-03-11 14:18:56 +0100
commita8a4b29621b959635ee333533bb2b3a905918581 (patch)
tree4d2eca0b4c37bf4a7746a54f5ad08a630819a5b3
parentc74b963608f1a73b08527950d67b86b0228709e6 (diff)
downloadaur-a8a4b29621b959635ee333533bb2b3a905918581.tar.gz
Use built-in systemd service file. Update PKGBUILD. Add pkgver().
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD70
-rw-r--r--sslh-fork.service10
-rw-r--r--sslh-git.install13
-rw-r--r--sslh-select.service9
-rw-r--r--sslh.conf29
-rw-r--r--sslh.sysusers1
7 files changed, 82 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f9efee21971..91b477eb509c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Mar 11 13:11:31 UTC 2016
pkgbase = sslh-git
- pkgdesc = SSL/SSH/OpenVPN/XMPP/tinc port multiplexer
- pkgver = 20100830
+ pkgdesc = Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port
+ pkgver = 1.17.r38.g8f39c10
pkgrel = 1
url = http://www.rutschle.net/tech/sslh.shtml
- install = sslh-git.install
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ depends = libcap
depends = libconfig
+ depends = systemd
provides = sslh
conflicts = sslh
backup = etc/sslh.conf
source = sslh-git::git+https://github.com/yrutschle/sslh
- source = sslh-select.service
- source = sslh-fork.service
+ source = sslh.conf
+ source = sslh.sysusers
md5sums = SKIP
- md5sums = 67e8c9511508673254afa3e1ca61ff89
- md5sums = a4402244a4d819beb3c6dc7ff031084e
+ md5sums = d5405c7ca7e1813e4d49a473e5834640
+ md5sums = f39544277a30595d4b7476b3f87ebbcf
pkgname = sslh-git
diff --git a/PKGBUILD b/PKGBUILD
index ff0a19a24707..45fcdd48352c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,57 @@
-pkgname=sslh-git
-pkgver=20100830
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=sslh
+pkgname=$_pkgname-git
+pkgver=1.17.r38.g8f39c10
pkgrel=1
-pkgdesc='SSL/SSH/OpenVPN/XMPP/tinc port multiplexer'
+pkgdesc="Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port"
arch=('i686' 'x86_64')
-url="http://www.rutschle.net/tech/sslh.shtml"
+url='http://www.rutschle.net/tech/sslh.shtml'
license=('GPL2')
-depends=('libconfig')
+depends=('libcap' 'libconfig' 'systemd')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
backup=('etc/sslh.conf')
-install=$pkgname.install
-source=("$pkgname"::'git+https://github.com/yrutschle/sslh'
- 'sslh-select.service'
- 'sslh-fork.service')
+source=($pkgname::'git+https://github.com/yrutschle/sslh'
+ 'sslh.conf'
+ 'sslh.sysusers')
md5sums=('SKIP'
- '67e8c9511508673254afa3e1ca61ff89'
- 'a4402244a4d819beb3c6dc7ff031084e')
-conflicts=('sslh')
-provides=('sslh')
-makedepends=('git')
+ 'd5405c7ca7e1813e4d49a473e5834640'
+ 'f39544277a30595d4b7476b3f87ebbcf')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$pkgname"
- make VERSION=\"v$pkgver\"
+ cd $pkgname
+ make VERSION=\"v$pkgver\" USELIBCAP=1 USELIBCONFIG=1 USESYSTEMD=1
}
package() {
- cd "$pkgname"
+ # Default Arch Linux config
+ install -Dm644 sslh.conf "$pkgdir/etc/sslh.conf"
- install -Dm 0755 sslh-fork "$pkgdir/usr/bin/sslh-fork"
- install -Dm 0755 sslh-select "$pkgdir/usr/bin/sslh-select"
+ # Systemd
+ install -Dm644 sslh.sysusers "$pkgdir/usr/lib/sysusers.d/sslh.conf"
+ cd $pkgname
+ install -Dm644 scripts/etc.sysconfig.sslh "$pkgdir/etc/conf.d/sslh"
+ install -Dm644 scripts/systemd.sslh.service "$pkgdir/usr/lib/systemd/system/sslh.service"
+
+ # Executables
+ install -Dm755 sslh-fork "$pkgdir/usr/bin/sslh-fork"
+ install -Dm755 sslh-select "$pkgdir/usr/bin/sslh-select"
ln -s sslh-fork "$pkgdir/usr/bin/sslh"
- # install manpage
- install -Dm 0644 sslh.8.gz "$pkgdir/usr/share/man/man8/sslh.8.gz"
- # install example file
- install -Dm 0644 example.cfg "$pkgdir/etc/sslh.conf"
- # systemd
- install -Dm 644 $srcdir/sslh-fork.service \
- "$pkgdir/usr/lib/systemd/system/sslh-fork.service"
- install -Dm 644 $srcdir/sslh-select.service \
- "$pkgdir/usr/lib/systemd/system/sslh-select.service"
+
+ # Manpage
+ install -Dm644 sslh.8.gz "$pkgdir/usr/share/man/man8/sslh.8.gz"
+
+ # Examples
+ install -Dm644 basic.cfg "$pkgdir/usr/share/doc/$pkgname/basic.cfg"
+ install -Dm644 example.cfg "$pkgdir/usr/share/doc/$pkgname/example.cfg"
+
}
# vim:set ts=2 sw=2 et:
diff --git a/sslh-fork.service b/sslh-fork.service
deleted file mode 100644
index cbfc41686b55..000000000000
--- a/sslh-fork.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=SSL/SSH multiplexer
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/sslh-fork -f -F /etc/sslh.conf
-KillMode=process
-
-[Install]
-WantedBy=multi-user.target
diff --git a/sslh-git.install b/sslh-git.install
deleted file mode 100644
index 46ce7beae9ed..000000000000
--- a/sslh-git.install
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- if [ "$(vercmp $2 1.14-1)" -le 0 ]; then
- cat << EOF
-===> sslh systemd service has been splitted in sslh-fork.service and sslh-select.service
-EOF
- fi
-}
-
-# vim:set ts=2 sw=2 ft=sh et:
diff --git a/sslh-select.service b/sslh-select.service
deleted file mode 100644
index 43f4f2787915..000000000000
--- a/sslh-select.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=SSL/SSH multiplexer
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/sslh-select -f -F /etc/sslh.conf
-
-[Install]
-WantedBy=multi-user.target
diff --git a/sslh.conf b/sslh.conf
new file mode 100644
index 000000000000..3a22a6e828e5
--- /dev/null
+++ b/sslh.conf
@@ -0,0 +1,29 @@
+# Default Arch configuration
+# You can find more examples in /usr/share/doc/sslh
+
+verbose: false;
+foreground: true;
+inetd: false;
+numeric: false;
+transparent: false;
+timeout: 2;
+user: "sslh";
+pidfile: "/run/sslh.pid";
+
+
+listen:
+(
+ { host: "::0"; port: "443"; }
+);
+
+protocols:
+(
+ { name: "ssh"; service: "ssh"; host: "localhost"; port: "22"; probe: "builtin"; },
+ { name: "openvpn"; host: "localhost"; port: "1194"; probe: "builtin"; },
+ { name: "xmpp"; host: "localhost"; port: "5222"; probe: "builtin"; },
+ { name: "http"; host: "localhost"; port: "80"; probe: "builtin"; },
+ { name: "ssl"; host: "localhost"; port: "8443"; probe: "builtin"; },
+ { name: "anyprot"; host: "localhost"; port: "8443"; probe: "builtin"; }
+);
+
+# vim:set ts=4 sw=4 et:
diff --git a/sslh.sysusers b/sslh.sysusers
new file mode 100644
index 000000000000..aebff9d6ca77
--- /dev/null
+++ b/sslh.sysusers
@@ -0,0 +1 @@
+u sslh - - -