summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-12-31 14:48:02 +0100
committerwillemw122016-12-31 14:48:02 +0100
commitf5be25e354fdf99ca382c9aef0b265a88825a6f3 (patch)
tree51b28d006311728bf0ff6698d8d96cf790c59915
parent7b3075c372be7fea5788cebffacfbf5e3e674434 (diff)
downloadaur-f5be25e354fdf99ca382c9aef0b265a88825a6f3.tar.gz
Fix compile errors. Add libcap.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4685319808d0..749015f7ef2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = sslh-git
pkgdesc = Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port
- pkgver = 1.18.r9.gf02ce38
+ pkgver = 1.18.r13.g718fe0e
pkgrel = 1
url = http://www.rutschle.net/tech/sslh.shtml
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ depends = libcap
depends = libconfig
depends = libwrap
depends = systemd
diff --git a/PKGBUILD b/PKGBUILD
index 443fa4c61e87..8ce8cbf44dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
_pkgname=sslh
pkgname=$_pkgname-git
-pkgver=1.18.r9.gf02ce38
+pkgver=1.18.r13.g718fe0e
pkgrel=1
pkgdesc="Network port multiplexer. Allows sharing of HTTP, SSL, SSH, OpenVPN, tinc, XMPP, etc. on the same port"
arch=('i686' 'x86_64')
url='http://www.rutschle.net/tech/sslh.shtml'
license=('GPL2')
-#depends=('libcap' 'libconfig' 'libwrap' 'systemd')
-depends=('libconfig' 'libwrap' 'systemd')
+depends=('libcap' 'libconfig' 'libwrap' 'systemd')
makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname)
@@ -33,8 +32,7 @@ prepare() {
build() {
cd $pkgname
- #make VERSION=\"v$pkgver\" USELIBCAP=1 USELIBCONFIG=1 USELIBWRAP=1 USESYSTEMD=1
- make VERSION=\"v$pkgver\" USELIBCAP= USELIBCONFIG=1 USELIBWRAP=1 USESYSTEMD=1
+ make
}
package() {