summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoll2019-04-03 16:09:56 +0200
committergoll2019-04-03 16:09:56 +0200
commitd5e3de67d0f162c1b397ac24a93f22967eba896a (patch)
treefa65ba1c62bfb412e0f0e16320d66821397b420b
downloadaur-d5e3de67d0f162c1b397ac24a93f22967eba896a.tar.gz
Initial commit 1.11.13-rbsec
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69e2655babdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sslscan-rbsec
+ pkgdesc = sslscan tests SSL/TLS enabled services to discover supported cipher suites
+ pkgver = 1.11.13
+ pkgrel = 1
+ url = https://github.com/rbsec/sslscan
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ conflicts = sslscan
+ conflicts = sslscan-git
+ source = https://github.com/rbsec/sslscan/archive/1.11.13-rbsec.tar.gz
+ sha256sums = 8a09c4cd1400af2eeeec8436a2f645ed0aae5576f4de045a09ea9ff099f56f4a
+
+pkgname = sslscan-rbsec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22830bc21b1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: goll <adrian.goll+aur[at]gmail>
+
+pkgname=sslscan-rbsec
+pkgver=1.11.13
+pkgrel=1
+pkgdesc="sslscan tests SSL/TLS enabled services to discover supported cipher suites"
+arch=('x86_64')
+url="https://github.com/rbsec/sslscan"
+license=('GPL3')
+makedepends=('git' 'gcc' 'make')
+conflicts=('sslscan' 'sslscan-git')
+source=("https://github.com/rbsec/sslscan/archive/${pkgver}-rbsec.tar.gz")
+sha256sums=('8a09c4cd1400af2eeeec8436a2f645ed0aae5576f4de045a09ea9ff099f56f4a')
+
+build() {
+ cd "${srcdir}/sslscan-${pkgver}-rbsec"
+ make static
+}
+
+package() {
+ cd "${srcdir}/sslscan-${pkgver}-rbsec"
+ install -D -m755 sslscan "${pkgdir}/usr/bin/sslscan"
+ install -D -m664 sslscan.1 "${pkgdir}/usr/share/man/man1/sslscan.1"
+ install -D -m664 LICENSE "${pkgdir}/usr/share/licenses/sslscan/LICENSE"
+}