summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2015-07-05 12:35:04 +0200
committerMichael Lass2015-07-07 14:00:22 +0200
commite5316983c05eef08e75aeb49b3111ab14c1810a5 (patch)
tree4648494b01cd05c7fbafe63ded3324513a603e8a
downloadaur-e5316983c05eef08e75aeb49b3111ab14c1810a5.tar.gz
Initial commit
Files taken from AUR3.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..973f2deb46c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sslyze
+ pkgdesc = Fast and full-featured SSL scanner.
+ pkgver = 0.11
+ pkgrel = 1
+ url = https://github.com/nabla-c0d3/sslyze
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2
+ source_i686 = https://github.com/nabla-c0d3/sslyze/releases/download/release-0.11/sslyze-0_11-linux32.zip
+ sha1sums_i686 = 9c62315fcee0aaa2a9ba68bd6bd7ea8e276af23f
+ source_x86_64 = https://github.com/nabla-c0d3/sslyze/releases/download/release-0.11/sslyze-0_11-linux64.zip
+ sha1sums_x86_64 = 45c6fe9eb53d6226e117a92d437fd2f31fbfe705
+
+pkgname = sslyze
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..205465d28d1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: goll <adrian.goll+aur[at]gmail>
+
+pkgname='sslyze'
+pkgver=0.11
+pkgrel=1
+pkgdesc="Fast and full-featured SSL scanner."
+arch=('i686' 'x86_64')
+url=('https://github.com/nabla-c0d3/sslyze')
+license=('GPL2')
+depends=('python2')
+source_i686=("https://github.com/nabla-c0d3/sslyze/releases/download/release-${pkgver}/${pkgname}-${pkgver/./_}-linux32.zip")
+source_x86_64=("https://github.com/nabla-c0d3/sslyze/releases/download/release-${pkgver}/${pkgname}-${pkgver/./_}-linux64.zip")
+sha1sums_i686=('9c62315fcee0aaa2a9ba68bd6bd7ea8e276af23f')
+sha1sums_x86_64=('45c6fe9eb53d6226e117a92d437fd2f31fbfe705')
+
+prepare() {
+ find $srcdir/*/$pkgname/ -type d -exec chmod 755 {} +
+}
+
+package() {
+ # Install files in /opt
+ mkdir -p "$pkgdir/opt/sslyze"
+ cp -a $srcdir/*/${pkgname}/. $pkgdir/opt/sslyze
+ find $pkgdir/opt/sslyze -type f -name '*.py' -print0 | xargs -0 sed -i 's/python/python2/'
+
+ # Create an indirect launcher in /usr/bin
+ mkdir -p "$pkgdir/usr/bin"
+
+cat << EOF > "$pkgdir/usr/bin/sslyze"
+#!/usr/bin/bash
+cd /opt/sslyze && python2 sslyze.py \$@
+EOF
+
+ chmod 755 "$pkgdir/usr/bin/sslyze"
+}