summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:53:15 -0700
committerAnatol Pomozov2015-06-17 08:53:15 -0700
commit0f983d168775f948e59d94f9afdf77e4eacad549 (patch)
tree3015cd885a60bff811721d0d8b54ea1879d2d7fd
downloadaur-0f983d168775f948e59d94f9afdf77e4eacad549.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..846b0c0ceff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ssmalloc-git
+ pkgdesc = A Low-latency, Locality-conscious Memory Allocator with Stable Performance Scalability
+ pkgver = r11.47f69d4
+ pkgrel = 1
+ url = http://ipads.se.sjtu.edu.cn/ssmalloc
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ source = git://github.com/Naruil/SSMalloc
+ sha1sums = SKIP
+
+pkgname = ssmalloc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7659350ddb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=ssmalloc-git
+pkgver=r11.47f69d4
+pkgrel=1
+pkgdesc='A Low-latency, Locality-conscious Memory Allocator with Stable Performance Scalability'
+arch=(x86_64)
+url='http://ipads.se.sjtu.edu.cn/ssmalloc'
+license=(BSD)
+makedepends=(git)
+source=(git://github.com/Naruil/SSMalloc)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd SSMalloc
+ # ssmalloc repo does not have any git tags yet
+ echo r$(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd SSMalloc
+ make
+}
+
+package() {
+ cd SSMalloc
+ mkdir -p "$pkgdir"/usr/lib
+ install libssmalloc.a "$pkgdir"/usr/lib
+ install libssmalloc.so "$pkgdir"/usr/lib
+ #make install DESTDIR="$pkgdir"
+}
+